aboutsummaryrefslogtreecommitdiffstats
path: root/main/libcrystalhd/gcc-opts-fix.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-05 09:42:10 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-05 09:42:10 +0200
commit467602b0a22fcc54d62c7c8c47ddeb50ce4ef181 (patch)
tree4fc23cfc94bec59ff3d5c26f2ef2765663d37499 /main/libcrystalhd/gcc-opts-fix.patch
parentd32e71e2c863ff7b3c95f2acf96fd104ab85dc2b (diff)
downloadaports-467602b0a22fcc54d62c7c8c47ddeb50ce4ef181.tar.bz2
aports-467602b0a22fcc54d62c7c8c47ddeb50ce4ef181.tar.xz
main/libcrystalhd: fix build on non-x86 machines
also remove unused patches
Diffstat (limited to 'main/libcrystalhd/gcc-opts-fix.patch')
-rw-r--r--main/libcrystalhd/gcc-opts-fix.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/main/libcrystalhd/gcc-opts-fix.patch b/main/libcrystalhd/gcc-opts-fix.patch
new file mode 100644
index 000000000..c89c43d7f
--- /dev/null
+++ b/main/libcrystalhd/gcc-opts-fix.patch
@@ -0,0 +1,17 @@
+Description: Patch to fix build failures on non x86 machines.
+Origin: Debian
+
+--- a/linux_lib/libcrystalhd/Makefile
++++ b/linux_lib/libcrystalhd/Makefile
+@@ -24,7 +24,10 @@
+ # -D_USE_SHMEM_
+
+ CPPFLAGS += ${INCLUDES}
+-CPPFLAGS += -O2 -Wall -fPIC -shared -fstrict-aliasing -msse2
++CPPFLAGS += -O2 -Wall -fPIC -shared -fstrict-aliasing
++MACHINE_OPTS = $(shell gcc -xc -c /dev/null -msse2 -o /dev/null \
++ >/dev/null 2>&1 && echo -msse2)
++CPPFLAGS += $(MACHINE_OPTS)
+ LDFLAGS = -Wl,-soname,${BCLIB_SL} -pthread
+
+ SRCFILES = libcrystalhd_if.cpp \