aboutsummaryrefslogtreecommitdiffstats
path: root/main/libfetch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-06 11:17:07 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 11:20:42 +0000
commit7412650df3959d8a6d7fa555f14d058915a8a238 (patch)
tree06cd2671bc0e06682dc29ff5263efa5669575836 /main/libfetch
parent4f22eabc253111ab64a1878dc8e4453449de6e03 (diff)
downloadaports-7412650df3959d8a6d7fa555f14d058915a8a238.tar.bz2
aports-7412650df3959d8a6d7fa555f14d058915a8a238.tar.xz
main/libfetch: support cross compiling
Diffstat (limited to 'main/libfetch')
-rw-r--r--main/libfetch/APKBUILD12
-rw-r--r--main/libfetch/Makefile6
2 files changed, 10 insertions, 8 deletions
diff --git a/main/libfetch/APKBUILD b/main/libfetch/APKBUILD
index b11f08c11..f695eef8e 100644
--- a/main/libfetch/APKBUILD
+++ b/main/libfetch/APKBUILD
@@ -1,13 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libfetch
pkgver=2.33
-pkgrel=0
+pkgrel=1
pkgdesc="URL based download library"
url="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
arch="all"
license="BSD"
depends=
-makedepends="openssl-dev"
+makedepends_build=""
+makedepends_host="openssl-dev"
+makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-dev $pkgname-doc"
source="Makefile
https://sources.archlinux.org/other/libfetch/libfetch-$pkgver.tar.gz
@@ -27,9 +29,9 @@ package() {
cd "$_builddir"
make DESTDIR=$pkgdir install
}
-md5sums="cf18907a75c67f543b1173d7f87830af Makefile
+md5sums="f04e037d98dcf18d37564a998d0ea9b1 Makefile
a176b94f7f30344ef8a71c047ca2136b libfetch-2.33.tar.gz"
-sha256sums="3329069346b1f325d2c8da55ecf77f341b01bd567d722dae009493aa8450e628 Makefile
+sha256sums="184cc1eae43e1336d39e183402c1835edfec89449163dcdc9f170d0d535b6e4d Makefile
3226f53d5ad29cc27510db968ef0d37bf4554b8aaaeadcd56e23067213b08943 libfetch-2.33.tar.gz"
-sha512sums="a712af971389d8eb182bc8f5c79f519785ed0f9aac6b71833d0a245a371720fe0dd0100de3d8d1071e94cd4c3b881d3345bf220fd76e0374b13934c8ff56ef45 Makefile
+sha512sums="58f5606de94077f01528d9081be9b605c394fcc5e481102cdba999b175b390e2549aa8c849666b0caa2c44c2b0638843d3108c8b4c27ddee3293c61eb2a012b6 Makefile
2d1fcd663733f5f44d9e87aa69a46e9aecfb465d1547d1469727c1a169768a8731c2f37761b93f35cfedba772dc8d66e472b26e10e2b7c6f7bf857d46f19af18 libfetch-2.33.tar.gz"
diff --git a/main/libfetch/Makefile b/main/libfetch/Makefile
index 9bc8c116d..38ed969c1 100644
--- a/main/libfetch/Makefile
+++ b/main/libfetch/Makefile
@@ -31,9 +31,9 @@ else
CFLAGS += -UDEBUG
endif
-CC = gcc
-LD = gcc
-AR = ar
+CC = $(CROSS_COMPILE)gcc
+LD = $(CROSS_COMPILE)gcc
+AR = $(CROSS_COMPILE)ar
RANLIB = ranlib
INSTALL = install -c -D