aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-07-13 14:52:08 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-13 12:32:50 +0000
commit990b6cb45af845d9a3fd3d7d32cebf4890aff37e (patch)
tree18e6e3be2716572ec1069da423f551cdb4947ad6 /main/linux-grsec
parent2a4023dfee4f68916ac96d02fc41874d7286d625 (diff)
downloadaports-990b6cb45af845d9a3fd3d7d32cebf4890aff37e.tar.bz2
aports-990b6cb45af845d9a3fd3d7d32cebf4890aff37e.tar.xz
main/linux-grsec: upgrade to 3.18.18
and cherry-pick a pmtu fix from linux.git
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch31
-rw-r--r--main/linux-grsec/APKBUILD20
2 files changed, 43 insertions, 8 deletions
diff --git a/main/linux-grsec/0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch b/main/linux-grsec/0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
new file mode 100644
index 000000000..4890abaa7
--- /dev/null
+++ b/main/linux-grsec/0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
@@ -0,0 +1,31 @@
+From 3cdaa5be9e81a914e633a6be7b7d2ef75b528562 Mon Sep 17 00:00:00 2001
+From: Li Wei <lw@cn.fujitsu.com>
+Date: Thu, 29 Jan 2015 16:09:03 +0800
+Subject: [PATCH] ipv4: Don't increase PMTU with Datagram Too Big message.
+
+RFC 1191 said, "a host MUST not increase its estimate of the Path
+MTU in response to the contents of a Datagram Too Big message."
+
+Signed-off-by: Li Wei <lw@cn.fujitsu.com>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ net/ipv4/route.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/net/ipv4/route.c b/net/ipv4/route.c
+index d58dd0e..52e1f2b 100644
+--- a/net/ipv4/route.c
++++ b/net/ipv4/route.c
+@@ -966,6 +966,9 @@ static void __ip_rt_update_pmtu(struct rtable *rt, struct flowi4 *fl4, u32 mtu)
+ if (dst->dev->mtu < mtu)
+ return;
+
++ if (rt->rt_pmtu && rt->rt_pmtu < mtu)
++ return;
++
+ if (mtu < ip_rt_min_pmtu)
+ mtu = ip_rt_min_pmtu;
+
+--
+2.4.5
+
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index af94a6669..71edc627e 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,7 +2,7 @@
_mainflavor=grsec
pkgname=linux-$_mainflavor
-pkgver=3.18.17
+pkgver=3.18.18
case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
@@ -17,10 +17,11 @@ options="!strip"
install=
source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$_kernver.tar.xz
http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.xz
- http://dev.alpinelinux.org/~tteras/grsec/grsecurity-3.1-3.18.17-201507050832-alpine.patch
+ http://dev.alpinelinux.org/~tteras/grsec/grsecurity-3.1-3.18.18-201507111210-alpine.patch
fix-memory-map-for-PIE-applications.patch
0001-ip_tunnel-fix-ipv4-pmtu-check-to-honor-inner-ip-head.patch
+ 0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
fix-spi-nor-namespace-clash.patch
imx6q-no-unclocked-sleep.patch
@@ -201,10 +202,11 @@ dev() {
}
md5sums="9e854df51ca3fef8bfe566dbd7b89241 linux-3.18.tar.xz
-ff54e954e26589a2a8a237bfe793ac41 patch-3.18.17.xz
-e4775dbac57c80905e2c2d99aedbfa1a grsecurity-3.1-3.18.17-201507050832-alpine.patch
+8d2baec3d5817eb5501d5b1141279ef6 patch-3.18.18.xz
+23230f4307dd6aac74266f7d80ef5ac9 grsecurity-3.1-3.18.18-201507111210-alpine.patch
c6a4ae7e8ca6159e1631545515805216 fix-memory-map-for-PIE-applications.patch
b7f15811ab0ae0a1225c03cc2cc24411 0001-ip_tunnel-fix-ipv4-pmtu-check-to-honor-inner-ip-head.patch
+5d708f155fff5fbbbeed2785423832e2 0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
b0337a2a9abed17c37eae5db332522d2 fix-spi-nor-namespace-clash.patch
1a307fc1d63231bf01d22493a4f14378 imx6q-no-unclocked-sleep.patch
9c3fdf1aba9dffc9a5ebc16a2ba37735 config-grsec.x86
@@ -213,10 +215,11 @@ b0337a2a9abed17c37eae5db332522d2 fix-spi-nor-namespace-clash.patch
18cb4521f9a8847637292f9f4c9e8256 config-virtgrsec.x86
80b45900be93b1183a6382adf710d961 config-virtgrsec.x86_64"
sha256sums="becc413cc9e6d7f5cc52a3ce66d65c3725bc1d1cc1001f4ce6c32b69eb188cbd linux-3.18.tar.xz
-190b769580a766add68c3e3a8878a725b36fe6877991f3af0cb4a1d6b5eeccf8 patch-3.18.17.xz
-98fc77df5d82ce127999923dadb203c9024f7539673b1c2efd46917939cb4864 grsecurity-3.1-3.18.17-201507050832-alpine.patch
+bd43b683811ecd3b9515a3047ded08a8263f02750e335b96dfc99bf589e90d9e patch-3.18.18.xz
+f416fc2bcdfa2eabed2680d55d102d78ca47e18f17fd206794ac285955f32452 grsecurity-3.1-3.18.18-201507111210-alpine.patch
500f3577310be52e87b9fecdc2e9c4ca43210fd97d69089f9005d484563f74c7 fix-memory-map-for-PIE-applications.patch
b4a5d6fc7b1dfe43cee18cf47db3f588a4b8a03e6d474af9a6f9ef487233ba70 0001-ip_tunnel-fix-ipv4-pmtu-check-to-honor-inner-ip-head.patch
+e6cef82ab135a8ab23111a90b95d3d034eaed32d7c5829c0322aaac491b781b7 0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
01279cfb93273d99670c56e2465957ecde3d03693beeb929a743f03afa0b7bdc fix-spi-nor-namespace-clash.patch
21179fbb22a5b74af0a609350ae1a170e232908572b201d02e791d2ce0a685d3 imx6q-no-unclocked-sleep.patch
5fc6db215c9566d937ed5162cea3a554352ba82a7b6754552e46d02ec39368d7 config-grsec.x86
@@ -225,10 +228,11 @@ c30182bf8c312141ef516154cbcf9ae6670dffeafa650126c2f375b5082087f3 config-grsec.x
47048993111506ab74db24c92d39b536cf5e684975844907d5cb6198c1dfd87f config-virtgrsec.x86
015ce51a03f1337673b47ef996b77c55cf50a28240e37c5ebf7e66f5886d3aef config-virtgrsec.x86_64"
sha512sums="2f0b72466e9bc538a675738aa416573d41bbbd7e3e2ffd5b5b127afde609ebc278cec5a3c37e73479607e957c13f1b4ed9782a3795e0dcc2cf8e550228594009 linux-3.18.tar.xz
-03a78cc7b72150570fd0f24ad44f491dc57913e0675f31b7322af8ccbf41deea05a0b04c7058f9c85352cb03a976b3817d3544d8c690cc67e26ec08672c09afa patch-3.18.17.xz
-0f0fec207e67fa96587159316fbc0be4b4559a9c437fdaeb8747d50ec59f34a6650c146f38138941489e364ea29e94aad72ff1f3d6ef92cccc0028b9514d12f6 grsecurity-3.1-3.18.17-201507050832-alpine.patch
+4f1c15256b9fd72f8dc97871ab680db889bdf8c7df9ba60d36054abfdc979676e9b11d74b0438021e612046f48bcae54dc57c2628c12accdcb4fcc29231aca46 patch-3.18.18.xz
+d5ee05c89c6416e70a92b0ae7f4ec5a4f1f7395e7e3ac1e5f7ee75f0a23aa2bc5cd8237cafa4defcd7ea1dd0e1e4bd30756019a8f90af4cacc07d98eff1a7832 grsecurity-3.1-3.18.18-201507111210-alpine.patch
4665c56ae1bbac311f9205d64918e84ee8b01d47d6e2396ff6b8adfb10aada7f7254531ce62e31edbb65c2a54a830f09ad05d314dfcd75d6272f4068945ad7c7 fix-memory-map-for-PIE-applications.patch
c5f7bda0a5bf88d7ce5de8c405ee5a018b652d70def2a5c6eea8e718b39efc0fed860bb61c70d950ba42cb11e0c264ee5ddd9a1505b7b60d19a56322ece894b6 0001-ip_tunnel-fix-ipv4-pmtu-check-to-honor-inner-ip-head.patch
+0d533a7ae0fd7a524326312d5e10f505936941826766b778508c91698e1ba5b7125248cc6fbbb6adc27db0f6172a68c818fb12818e6d6a27cf4f85a961013bdb 0002-ipv4-Don-t-increase-PMTU-with-Datagram-Too-Big-messa.patch
4e3aeb70712f9838afea75fe9e6c1389414d833a89286ea55441d6a8d54ce74b0e39b565721e3153443af0a614bff57c767251b7e5b81faa5e0784eddfcd2164 fix-spi-nor-namespace-clash.patch
87d1ad59732f265a5b0db54490dc1762c14ea4b868e7eb1aedc3ce57b48046de7bbc08cf5cfcf6f1380fa84063b0edb16ba3d5e3c5670be9bbb229275c88b221 imx6q-no-unclocked-sleep.patch
1c8861bd213f2ed5a5d4b6205ca3453958f110ad0245940c824a3ef3983a10a937adf7e401f087d7cc6e6d0054cbb187139ef426b6e00d7fa707aab20f1d2666 config-grsec.x86