aboutsummaryrefslogtreecommitdiffstats
path: root/main/patchwork
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-03-31 09:32:54 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-03-31 09:32:58 +0000
commit0616c2087e49917c3eff95041993b395ea8789cf (patch)
tree79be5fd230ca976711df82b693ad7fcc7bbfdd48 /main/patchwork
parent9826cf80d4897c633bdf58e9a918a35184f8c09d (diff)
downloadaports-0616c2087e49917c3eff95041993b395ea8789cf.tar.bz2
aports-0616c2087e49917c3eff95041993b395ea8789cf.tar.xz
main/patchwork: upgrade to v1.1.1. Added nginx and uwsgi support
Diffstat (limited to 'main/patchwork')
-rw-r--r--main/patchwork/APKBUILD37
-rw-r--r--main/patchwork/nginx-uwsgi-patchwork-conf.ini26
-rw-r--r--main/patchwork/uwsgi.patchwork.confd11
3 files changed, 65 insertions, 9 deletions
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
index 919fd7ff7..7243ed963 100644
--- a/main/patchwork/APKBUILD
+++ b/main/patchwork/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=0
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
@@ -11,11 +11,13 @@ depends="py-django py-django-registration git py-psycopg2"
depends_dev=""
makedepends="$depends_dev"
install=""
-subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-mysql
+subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-nginx_wsgi $pkgname-mysql
$pkgname-postgresql pwclient:pwclient"
source="$pkgname-$pkgver.tar.gz::https://github.com/getpatchwork/$pkgname/archive/v$pkgver.tar.gz
0001-support-busybox-readlink.patch
- 0002-remove-uneeded-bashism-from-tools-and-change-path.patch"
+ 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+ nginx-uwsgi-patchwork-conf.ini
+ uwsgi.patchwork.confd"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -54,6 +56,17 @@ apache2_wsgi() {
"$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf || return 1
}
+nginx_wsgi() {
+ pkgdesc="$pkgname nginx wsgi support"
+ depends="nginx uwsgi-python"
+ install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/nginx/patchwork.conf \
+ "$subpkgdir"/etc/nginx/conf.d/patchwork.conf || return 1
+ install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
+ "$subpkgdir"/etc/patchwork/patchwork.ini || return 1
+ install -Dm644 "$srcdir"/uwsgi.patchwork.confd \
+ "$subpkgdir"/etc/conf.d/uwsgi.patchwork || return 1
+}
+
mysql() {
pkgdesc="$pkgname mysql support"
depends="py-mysqldb"
@@ -73,12 +86,18 @@ pwclient() {
"$subpkgdir"/usr/bin/pwclient || return 1
}
-md5sums="4eb35ccb163b8effdbd200a4634177b8 patchwork-1.1.0.tar.gz
+md5sums="9d665f68edc1afc6883873bb89dafe48 patchwork-1.1.1.tar.gz
c0bf2a78294773e6a5dc5fb5c9b525cf 0001-support-busybox-readlink.patch
-2dde450ee27a24ea4b0448b1331e7cc9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch"
-sha256sums="28fe96632b3eba23869aaba9d63cfc199440b772acfe38a8827241a5053629d0 patchwork-1.1.0.tar.gz
+2dde450ee27a24ea4b0448b1331e7cc9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+698b5d0dedc03e76b6f9a33738c44e79 nginx-uwsgi-patchwork-conf.ini
+e3b6d46baf11e59a6547c8c0ff11935e uwsgi.patchwork.confd"
+sha256sums="e5bb8c453b2d042d13f87b51cba10360bd1d84ff181d6f2ee011c3b600c613f0 patchwork-1.1.1.tar.gz
43159a12dbbd4161ae1476c38b5435517dbc7260a1e25aa6263038cc4c267b99 0001-support-busybox-readlink.patch
-499fc47ac715901fe0a5f5043f7ee722ab39e694451c70982830e1c728ea136d 0002-remove-uneeded-bashism-from-tools-and-change-path.patch"
-sha512sums="9b8308cb210fac58163a0f4acb3d8105593ed3c60c673f9e372b9ef27366aca3af34a0143a936939ef05a7fbb303e739924a427b31905e6773e24e19f938b57b patchwork-1.1.0.tar.gz
+499fc47ac715901fe0a5f5043f7ee722ab39e694451c70982830e1c728ea136d 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+51c1f9c32aff324b685b2d34200f528953d9f0e774eefd69d3b7788c1b16b3d8 nginx-uwsgi-patchwork-conf.ini
+e9054b0b7510f40e240619d6edf58200d3a759f3d87cbf78bcf4a5177ece1569 uwsgi.patchwork.confd"
+sha512sums="2f2f9114a2185ca34d493a87d34f16cfb4bc05f4c6c261f533faa9cbaded7b77a37f202715668bb428462848733ff042a130271addb28f89445ad22e212376d7 patchwork-1.1.1.tar.gz
a5d4e24741b66092a39c1ef4fdc76dffa1ddf87a69544ab0c374fb0701b0f7340a62ead86835d9bb412df5713f3ea3c0218e9e2e0cd01d9a1aad9414a3cc75fa 0001-support-busybox-readlink.patch
-12d1b184c6cb1d3f2c51adab6b60638e4869e055e677897bb66ee1a52312e77817bec543842324e2cbc2c226f3ab9d11c3782b5ef3a6f5f5712996cadbc6c9c9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch"
+12d1b184c6cb1d3f2c51adab6b60638e4869e055e677897bb66ee1a52312e77817bec543842324e2cbc2c226f3ab9d11c3782b5ef3a6f5f5712996cadbc6c9c9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+6bafda9fbd067b8f54fbff13cb28afe99ee1f26bb1b6f212264a8c9f3eb2723394b9c9ccea2fe97677505f32b324462f1646ac1990f1cce41cfbbbd19de9f701 nginx-uwsgi-patchwork-conf.ini
+a06c6176e44f5e2c04eb8609e3b8595ea59782e6f6167dcbb50a0af3163e484096c876bcb0cd67b18cb826eef4665f368aa8d9e5ccd32eab9bd5ca2ca8e2d080 uwsgi.patchwork.confd"
diff --git a/main/patchwork/nginx-uwsgi-patchwork-conf.ini b/main/patchwork/nginx-uwsgi-patchwork-conf.ini
new file mode 100644
index 000000000..bc487ca27
--- /dev/null
+++ b/main/patchwork/nginx-uwsgi-patchwork-conf.ini
@@ -0,0 +1,26 @@
+[uwsgi]
+project = patchwork
+base = /usr/share/webapps
+user = nginx
+group = www-data
+
+chdir = %(base)/%(project)
+pythonpath = %(base)/%(project)
+module = %(project).wsgi:application
+wsgi-file = %(project)/wsgi.py
+plugins = python
+
+master = true
+processes = 4
+# increase buffer size to avoid "502 bad gateway error"
+# "recv() failed (104: Connection reset by peer) while reading response header from upstream"
+buffer-size = 16384
+
+uid = %(user)
+gid = %(group)
+
+daemonize = /var/log/%(project).log
+socket = /run/%(project).sock
+chown-socket = nginx:www-data
+chmod-socket = 665
+vacuum = true
diff --git a/main/patchwork/uwsgi.patchwork.confd b/main/patchwork/uwsgi.patchwork.confd
new file mode 100644
index 000000000..febc0b549
--- /dev/null
+++ b/main/patchwork/uwsgi.patchwork.confd
@@ -0,0 +1,11 @@
+UWSGI_SOCKET=
+UWSGI_THREADS=0
+UWSGI_PROGRAM=
+UWSGI_XML_CONFIG=
+UWSGI_PROCESSES=5
+UWSGI_LOG_FILE=
+UWSGI_CHROOT=
+UWSGI_DIR=
+UWSGI_USER=
+UWSGI_GROUP=
+UWSGI_EXTRA_OPTIONS="--ini /etc/patchwork/patchwork.ini"