aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-sunleo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-17 10:50:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-17 11:01:25 +0000
commit0ee7f34aa4df6bc0c12677a0f16deebca2a402c8 (patch)
tree15e9cd18f7de2b748b99a463e20845689f6009b8 /main/xf86-video-sunleo
parentdf93713f53333c52a6f24d558330baf21c6a9915 (diff)
downloadaports-0ee7f34aa4df6bc0c12677a0f16deebca2a402c8.tar.bz2
aports-0ee7f34aa4df6bc0c12677a0f16deebca2a402c8.tar.xz
main/xf86-video-sunleo: rebuild against xorg-server 1.17
Diffstat (limited to 'main/xf86-video-sunleo')
-rw-r--r--main/xf86-video-sunleo/APKBUILD29
-rw-r--r--main/xf86-video-sunleo/git-fixes.patch42
2 files changed, 64 insertions, 7 deletions
diff --git a/main/xf86-video-sunleo/APKBUILD b/main/xf86-video-sunleo/APKBUILD
index ce5f226d3..68e05710c 100644
--- a/main/xf86-video-sunleo/APKBUILD
+++ b/main/xf86-video-sunleo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-sunleo
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Leo video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,10 +11,22 @@ depends=
makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ git-fixes.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -25,11 +37,14 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="6f998ea58bf3c86307991cce67720940 xf86-video-sunleo-1.2.1.tar.bz2"
-sha256sums="1ace84e14edbbf76728d61af7b1440a461ddf22f1dba0f025879d286311f491d xf86-video-sunleo-1.2.1.tar.bz2"
-sha512sums="52f1578dba4f77e2d999ea2017325df6ac324d60ec2e62677ef9a900aabb183650bcd0923b5a0a1cd7c13c9e80c8a47223b96be651e5a5ecb635654f3eb67af1 xf86-video-sunleo-1.2.1.tar.bz2"
+md5sums="6f998ea58bf3c86307991cce67720940 xf86-video-sunleo-1.2.1.tar.bz2
+c3199c542604db52a3c43cc79da64ebd git-fixes.patch"
+sha256sums="1ace84e14edbbf76728d61af7b1440a461ddf22f1dba0f025879d286311f491d xf86-video-sunleo-1.2.1.tar.bz2
+b185411f00b19214b9e95b2ca766373b652e9f94ca9a06cdf8fdc08dca07c359 git-fixes.patch"
+sha512sums="52f1578dba4f77e2d999ea2017325df6ac324d60ec2e62677ef9a900aabb183650bcd0923b5a0a1cd7c13c9e80c8a47223b96be651e5a5ecb635654f3eb67af1 xf86-video-sunleo-1.2.1.tar.bz2
+0d299c8e26b585536dc2d97ebdfff243e15f600e4b35fe377b17cf0031b5419719d980da017981eb0881f067d4497538061c1b60e20107cfed13b6eedff51dd8 git-fixes.patch"
diff --git a/main/xf86-video-sunleo/git-fixes.patch b/main/xf86-video-sunleo/git-fixes.patch
new file mode 100644
index 000000000..2b973b883
--- /dev/null
+++ b/main/xf86-video-sunleo/git-fixes.patch
@@ -0,0 +1,42 @@
+From e9b0b0d5765fb9b20be05642f01531c41d148335 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Wed, 12 Nov 2014 11:03:08 +1000
+Subject: drop mifillarc.h include
+
+
+diff --git a/src/leo_accel.c b/src/leo_accel.c
+index 3c509ba..2ecb759 100644
+--- a/src/leo_accel.c
++++ b/src/leo_accel.c
+@@ -34,7 +34,6 @@
+ #include <X11/fonts/fontstruct.h>
+ #include "dixfontstr.h"
+ #include "fb.h"
+-#include "mifillarc.h"
+ #include "miwideline.h"
+ #include "mi.h"
+
+--
+cgit v0.10.2
+
+From 7cab298aa9ea095237c1ab288496d6deb05c3f67 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Wed, 12 Nov 2014 14:17:35 +1000
+Subject: drop miwideline.h include
+
+
+diff --git a/src/leo_accel.c b/src/leo_accel.c
+index 2ecb759..3981f61 100644
+--- a/src/leo_accel.c
++++ b/src/leo_accel.c
+@@ -34,7 +34,6 @@
+ #include <X11/fonts/fontstruct.h>
+ #include "dixfontstr.h"
+ #include "fb.h"
+-#include "miwideline.h"
+ #include "mi.h"
+
+ #include "leo.h"
+--
+cgit v0.10.2
+