aboutsummaryrefslogtreecommitdiffstats
path: root/main/xfce4-whiskermenu-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-05 18:41:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-05 18:41:31 +0000
commitba0f3be3099a8fc278db4eba81501e2d8a513b04 (patch)
tree2c4866de37d10c7641b87d3ce3cc2256b4d12f23 /main/xfce4-whiskermenu-plugin
parent4b9c3d6db959cb321dcc46c4831c20cdecaef42b (diff)
downloadaports-ba0f3be3099a8fc278db4eba81501e2d8a513b04.tar.bz2
aports-ba0f3be3099a8fc278db4eba81501e2d8a513b04.tar.xz
main/xfce4-whiskermenu-plugin: moved from testing
Diffstat (limited to 'main/xfce4-whiskermenu-plugin')
-rw-r--r--main/xfce4-whiskermenu-plugin/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/xfce4-whiskermenu-plugin/APKBUILD b/main/xfce4-whiskermenu-plugin/APKBUILD
new file mode 100644
index 000000000..6e08818c5
--- /dev/null
+++ b/main/xfce4-whiskermenu-plugin/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-whiskermenu-plugin
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="alternate application launcher for Xfce"
+url="http://gottcode.org/xfce4-whiskermenu-plugin/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake libxfce4ui-dev libxfce4util-dev exo-dev
+ garcon-dev xfce4-panel-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://gottcode.org/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-$pkgver-src.tar.bz2"
+
+_builddir="$srcdir"/xfce4-whiskermenu-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install LIBDIR=lib DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="0c78f2b1cb3883d636cb616ab96e92be xfce4-whiskermenu-plugin-1.4.0-src.tar.bz2"
+sha256sums="0f75f4551357a19200d14aa4df69755291a9db1b6fd49ab7ac51fd795c0a87e2 xfce4-whiskermenu-plugin-1.4.0-src.tar.bz2"
+sha512sums="1055e6d31ca6d2077a0d34524c5231f354a865e626ad2870af6a426dc368684b9a0e333d1476e2ae081553f4aff69581bfe1ce68948dc129c115806d82e62e70 xfce4-whiskermenu-plugin-1.4.0-src.tar.bz2"