aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-04-10 05:15:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-04-10 05:15:09 +0000
commitbcd74e3bc6400e2d63ccfc077f31b211f35e9a9b (patch)
treeb9081b30885b8ef4ee77d282bc55e4ea67e30890 /testing/firefox
parentc9d2af8d1692ac566274cc369043becbaf1dab9b (diff)
downloadaports-bcd74e3bc6400e2d63ccfc077f31b211f35e9a9b.tar.bz2
aports-bcd74e3bc6400e2d63ccfc077f31b211f35e9a9b.tar.xz
testing/firefox: use paxmark
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index def13032f..7ece83e47 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=37.0.1
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -41,7 +41,7 @@ makedepends="$depends_dev
automake
bsd-compat-headers
libtool
- paxctl
+ paxmark
python
sed
yasm
@@ -115,7 +115,7 @@ package() {
# only used for startupcache creation.
local paxflags="-msp"
- paxctl -c $paxflags */dist/bin/xpcshell || return 1
+ paxmark "$paxflags" */dist/bin/xpcshell || return 1
make -j1 -f client.mk install \
DESTDIR="$pkgdir" \
@@ -133,7 +133,7 @@ package() {
local paxflags="-mp"
[ "$CARCH" = "x86" ] && paxflags="-msp"
- paxctl -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1
+ paxmark "$paxflags" "$pkgdir"/$_mozappdir/firefox || return 1
# xulrunner stub launcher has changed to using a symlink overlay...
# go figure