aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ipt-netflow-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-07-11 16:13:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-11 16:38:20 +0000
commit823bb4049babc532fcf899a11091a0dc5358284f (patch)
treef23922b5b9af078b87588e8130e9134ee60073f7 /testing/ipt-netflow-grsec
parentbda6ac8ffaba63316bd825e641dfcd119bfd2108 (diff)
downloadaports-823bb4049babc532fcf899a11091a0dc5358284f.tar.bz2
aports-823bb4049babc532fcf899a11091a0dc5358284f.tar.xz
testing/ipt-netflow-grsec: rebuild against kernel 4.4.14-r1
Diffstat (limited to 'testing/ipt-netflow-grsec')
-rw-r--r--testing/ipt-netflow-grsec/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/ipt-netflow-grsec/APKBUILD b/testing/ipt-netflow-grsec/APKBUILD
index af36ba52c..021dee938 100644
--- a/testing/ipt-netflow-grsec/APKBUILD
+++ b/testing/ipt-netflow-grsec/APKBUILD
@@ -3,7 +3,7 @@
_flavor=grsec
_kpkg=linux-$_flavor
_kver=4.4.14
-_kpkgrel=0
+_kpkgrel=1
# when chaning _ver we *must* bump _mypkgrel
_ver=2.1
@@ -51,12 +51,13 @@ build() {
./configure --kver=$_abi_release \
--ipt-inc=/usr/include/libiptc \
|| return 1
- make ipt_NETFLOW.ko || return 1
+ make KCFLAGS="-fno-pie" ipt_NETFLOW.ko || return 1
}
package() {
cd "$_builddir"
- make -j1 minstall DEPMOD=: DESTDIR="$pkgdir" || return 1
+ make -j1 minstall KCFLAGS="-fno-pie" DEPMOD=: DESTDIR="$pkgdir" \
+ || return 1
}
# override dev() from kernel's APKBUILD