aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongodb
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-12-18 14:30:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-12-18 14:30:28 +0000
commit97ce02ff30a7d6b73271919686f8efc1f8e2461a (patch)
treea9b12b7794eed06583370dc3b022bbcce7f838dd /testing/mongodb
parent3afa43694d2bfcb8401e198114b238eab4a133b4 (diff)
downloadaports-97ce02ff30a7d6b73271919686f8efc1f8e2461a.tar.bz2
aports-97ce02ff30a7d6b73271919686f8efc1f8e2461a.tar.xz
testing/mongodb: upgrade to 3.0.6
Diffstat (limited to 'testing/mongodb')
-rw-r--r--testing/mongodb/20-fix-libc-version.patch55
-rw-r--r--testing/mongodb/APKBUILD30
-rw-r--r--testing/mongodb/mongodb.initd2
-rw-r--r--testing/mongodb/mongos.initd2
4 files changed, 46 insertions, 43 deletions
diff --git a/testing/mongodb/20-fix-libc-version.patch b/testing/mongodb/20-fix-libc-version.patch
index bf1aba081..3b213cc3d 100644
--- a/testing/mongodb/20-fix-libc-version.patch
+++ b/testing/mongodb/20-fix-libc-version.patch
@@ -1,5 +1,34 @@
---- orig/mongodb-src-r3.0.2/src/mongo/util/processinfo_linux2.cpp
-+++ mongodb-src-r3.0.2/src/mongo/util/processinfo_linux2.cpp
+diff --git a/src/mongo/util/processinfo_linux2.cpp b/src/mongo/util/processinfo_linux2.cpp
+index d1ed23a..0c1011e 100644
+--- a/src/mongo/util/processinfo_linux2.cpp
++++ b/src/mongo/util/processinfo_linux2.cpp
+@@ -335,6 +335,7 @@ public:
+ paths.push_back("/etc/debian_release");
+ paths.push_back("/etc/slackware-version");
+ paths.push_back("/etc/centos-release");
++ paths.push_back("/etc/alpine-release");
+ paths.push_back("/etc/os-release");
+
+ for (i = paths.begin(); i != paths.end(); ++i) {
+@@ -421,10 +422,10 @@ double ProcessInfo::getSystemMemoryPressurePercentage() {
+
+ void ProcessInfo::getExtraInfo(BSONObjBuilder& info) {
+ // [dm] i don't think mallinfo works. (64 bit.) ??
+- struct mallinfo malloc_info =
+- mallinfo(); // structure has same name as function that returns it. (see malloc.h)
+- info.append("heap_usage_bytes",
+- malloc_info.uordblks /*main arena*/ + malloc_info.hblkhd /*mmap blocks*/);
++ //struct mallinfo malloc_info =
++ // mallinfo(); // structure has same name as function that returns it. (see malloc.h)
++ // TODO: Fix for TC_malloc instance().getStats()
++ info.append("heap_usage_bytes", 0);
+ // docs claim hblkhd is included in uordblks but it isn't
+
+ LinuxProc p(_pid);
+diff --git a/src/mongo/util/processinfo_linux2.cpp b/src/mongo/util/processinfo_linux2.cpp
+index 0c1011e..755a2cc 100644
+--- a/src/mongo/util/processinfo_linux2.cpp
++++ b/src/mongo/util/processinfo_linux2.cpp
@@ -34,7 +34,11 @@
#include <stdio.h>
#include <unistd.h>
@@ -13,25 +42,3 @@
#include <sys/utsname.h>
#include "processinfo.h"
-@@ -314,6 +318,7 @@
- paths.push_back( "/etc/slackware-version" );
- paths.push_back( "/etc/centos-release" );
- paths.push_back( "/etc/os-release" );
-+ paths.push_back( "/etc/alpine-release" );
-
- for ( i = paths.begin(); i != paths.end(); ++i ) {
- // for each path
-@@ -398,8 +403,11 @@
-
- void ProcessInfo::getExtraInfo( BSONObjBuilder& info ) {
- // [dm] i don't think mallinfo works. (64 bit.) ??
-- struct mallinfo malloc_info = mallinfo(); // structure has same name as function that returns it. (see malloc.h)
-- info.append("heap_usage_bytes", malloc_info.uordblks/*main arena*/ + malloc_info.hblkhd/*mmap blocks*/);
-+ //struct mallinfo malloc_info = mallinfo(); // structure has same name as function that returns it. (see malloc.h)
-+ // info.append("heap_usage_bytes", malloc_info.uordblks/*main arena*/ + malloc_info.hblkhd/*mmap blocks*/);
-+
-+ // TODO: Fix for TC_malloc instance().getStats()
-+ info.append("heap_usage_bytes", 0);
- //docs claim hblkhd is included in uordblks but it isn't
-
- LinuxProc p(_pid);
diff --git a/testing/mongodb/APKBUILD b/testing/mongodb/APKBUILD
index 0c61a2fcd..ad1c81723 100644
--- a/testing/mongodb/APKBUILD
+++ b/testing/mongodb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Filipp Andronov <filipp.andronov@gmail.com>
pkgname=mongodb
-pkgver=3.0.4
+pkgver=3.0.6
pkgrel=0
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
@@ -13,7 +13,6 @@ depends_dev="scons openssl-dev libexecinfo-dev pcre-dev wiredtiger-dev"
makedepends="$depends_dev"
install="$pkgname.pre-install"
source="http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz
- 10-fix-poll-h.patch
20-fix-libc-version.patch
30-fix-backtrace.patch
40-fix-elf-native-class.patch
@@ -80,33 +79,30 @@ package() {
install -Dm644 "$srcdir/mongos.confd" "$pkgdir/etc/conf.d/mongos"
}
-md5sums="d81ff3c814dd5258fde0687da1ac5bf4 mongodb-src-r3.0.4.tar.gz
-b37ef33a58cbfddd7272b2e3e7c29d18 10-fix-poll-h.patch
-c30067f1f39707371db5897dbd46012f 20-fix-libc-version.patch
+md5sums="1cda3caf0d63ce9bae20de0fec7baccd mongodb-src-r3.0.6.tar.gz
+9419a078d1cc62d6cb27d9585028e3c3 20-fix-libc-version.patch
4b27b6c9d0216234ac6a24106b624381 30-fix-backtrace.patch
04a348397be8ca7471d404056d8a1490 40-fix-elf-native-class.patch
7d2f94bed7bfacd32fcd52dfd931f077 mongodb.confd
-7bfbe9bd5da9254ab4981c7c3b8ac2bc mongodb.initd
+792a0b53b3e843cf14176c5beb8cdfe1 mongodb.initd
49df78833de4cb6e2b9b1ab9da52c3ac mongodb.logrotate
33b23ee722f6e5d15eb6d9c2723a346f mongos.confd
-e2e7904c561364545a48077ba4e84dc3 mongos.initd"
-sha256sums="6de7aa8b12ad892ee3852ac949069fda8cb87b3ee606a88226817505e2864360 mongodb-src-r3.0.4.tar.gz
-7eff5c3f9d0119c19b9144d0933f2cd60db0490e096d4b34c1578101ad06ba33 10-fix-poll-h.patch
-1cc23b97d2c0fcec0c67418c9d3fe842fd121fd7e0596ef4ae77b1b992919631 20-fix-libc-version.patch
+28611e6796d71c21661dd3d7ee8f23b8 mongos.initd"
+sha256sums="609f6bd416ed11898b49406332b8ff301de239ba72df0bdbf1603233229c822d mongodb-src-r3.0.6.tar.gz
+dc536f728b27e0a01406a4a99afd4f02e86514d225ad7eb71834bc18db6b9861 20-fix-libc-version.patch
7630b7b55cd2b3e836c441e5ac13b4a111ef3552a9576433a58bd839a1b9259b 30-fix-backtrace.patch
3a863660113d29728d7a852b3fba73926697b496848f8ccc4d8e73e6614cfdfc 40-fix-elf-native-class.patch
a4ca29c577428c02cd0b0a8b46756df5f53a05519c9d13c270533cf99b9b819d mongodb.confd
-ee590071ade60cffdd28ce5bd1e685bcfb49878fb88a21adea0cf30867587ade mongodb.initd
+7e39fbd4dc18dba21c8767931683f4795e58e0e91b9f9a5842539923ded453c9 mongodb.initd
76994c32d999def5c925bd7be3f96687b3406f1d67b89aa6a4df8053025b1e01 mongodb.logrotate
2afd582564623da0e928ca667d37bef467334c82d08b49301f1f6c16ba177767 mongos.confd
-0b7dafba846962f473c406e09d80923e07cf03bb8ba727b3e0408fbef28b23da mongos.initd"
-sha512sums="bd35a252cd351a2d755edf5e20c69c904de326d7e47aebc055cd0160476ecf966cf53f3263410c32f70e108ff2a019f86a21e1a71917246c2f13db9251082bc3 mongodb-src-r3.0.4.tar.gz
-73427e35edaf6e6c3b9b2fc16ef4560fc3765084d840bdbec729445fa24ca87394798db16366e0ec320312b3c3b6e1fe58db013e902a2b1413c36b8e66c6bce8 10-fix-poll-h.patch
-b9c9f5dbefe765b3cd1043c259dda027721bf66e75024ec70c0d84fe6a1039065b133c3ea838e01538535d07e308c8629920b11fff51a304d0bf59d04ee3ad9b 20-fix-libc-version.patch
+1c48327b02bb9e1aaacaa39a4c0e9976a765a0ab0992d4e27cc4c36a33fefe2d mongos.initd"
+sha512sums="1990e9011ae586e30aef28be58f9fc6d8b7f45b787dbde9785c82eff6fb0a70ea45152e450c032a898e6464bbb9b1683082f2a072ba874f7532e167330658175 mongodb-src-r3.0.6.tar.gz
+08a2ec09d4cce55e00eb8dce3b52c0f8a6dfca9f67b6194934ec95afef1c60efb8982ae6b88bff571591cdfeede6a732879ab0f201a78a794530ff0a7e917dd1 20-fix-libc-version.patch
914c896c7736330834a2a66b60615656b67df5348c65b8ba48478e98044d1fae781082aa510263a7f7a3cb13fa2c019747600250e5b584a12870553cf9fe1f99 30-fix-backtrace.patch
56db8f43afc94713ac65b174189e2dd903b5e1eff0b65f1bdac159e52ad4de6606c449865d73bd47bffad6a8fc339777e2b11395596e9a476867d94a219c7925 40-fix-elf-native-class.patch
9bcd870742c31bf25f34188ddc3c414de1103e9860dea9f54eee276b89bc2cf1226abab1749c5cda6a6fb0880e541373754e5e83d63cc7189d4b9c274fd555c3 mongodb.confd
-c0634af4653a3b3ca1a72671460e8ea11cce99b84a48782c5cdcc27453d7ead1e89a61d0ce225febda68913dd04e972b4d6a911060b1e5c4ecfbfc1e991e7b12 mongodb.initd
+2cb295ac0eb44acb4533c86d6d0988d5f760361a43cff7845713f3e2cf0e37023d23790a2926c613bf2b0668060c0b68d59000db52daaacd8af10e701a8b4192 mongodb.initd
8c089b1a11f494e4148fb4646265964c925bf937633a65e395ee1361d42facf837871dd493a9a2e0f480ae0e0829dbd3ed60794c5334e2716332e131fc5c2c51 mongodb.logrotate
61d8734cef644187eeadc821c89e63a3fbf61860fe2db6e74557b1c6760fe83ba7549cb04f9e3aacea4d8e7e4d81a3b1bc0d5e29715eca33c4761adb17ea9ab7 mongos.confd
-28b54e19efd977721549b95e23d34b070c1af0648d5ae60e2457c86a3c18e5cbb6a56fa147d13a38ac540cf9315ac8f74cddaa3c7baafc56c8c6e5596ebef0c0 mongos.initd"
+13aad7247b848ac58b2bc0b40a0d30d909e950380abd0c83fab0e2a394a42dc268a66dac53cf9feec6971739977470082cc4339cca827f41044cfe43803ef3f7 mongos.initd"
diff --git a/testing/mongodb/mongodb.initd b/testing/mongodb/mongodb.initd
index 5b7b77eeb..a6d996232 100644
--- a/testing/mongodb/mongodb.initd
+++ b/testing/mongodb/mongodb.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/files/mongodb.initd,v 1.5 2013/01/18 11:19:27 ultrabug Exp $
diff --git a/testing/mongodb/mongos.initd b/testing/mongodb/mongos.initd
index 2f9bd9a6e..a38fc5056 100644
--- a/testing/mongodb/mongos.initd
+++ b/testing/mongodb/mongos.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/files/mongos.initd,v 1.3 2013/01/18 11:19:27 ultrabug Exp $