aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocamlbuild
diff options
context:
space:
mode:
authorJon Ong <jonongjs@rottenmage.com>2016-07-07 23:42:45 +0800
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-08 09:53:42 +0200
commitd73dca5d546233fd38bd8c3c3d3682f111c53626 (patch)
tree16995fd70a1e052097c1632b4edb915b64030431 /testing/ocamlbuild
parentec3a1b4087eb88aaa6a7261dff7c2f16d99edf6f (diff)
downloadaports-d73dca5d546233fd38bd8c3c3d3682f111c53626.tar.bz2
aports-d73dca5d546233fd38bd8c3c3d3682f111c53626.tar.xz
testing/ocamlbuild: new aport
https://github.com/ocaml/ocamlbuild Generic build tool with built-in rules for building OCaml library and programs.
Diffstat (limited to 'testing/ocamlbuild')
-rw-r--r--testing/ocamlbuild/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/ocamlbuild/APKBUILD b/testing/ocamlbuild/APKBUILD
new file mode 100644
index 000000000..474fb9538
--- /dev/null
+++ b/testing/ocamlbuild/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer:
+pkgname=ocamlbuild
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="Generic build tool with built-in rules for building OCaml library and programs."
+url="https://github.com/ocaml/ocamlbuild"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="ocaml"
+options=""
+install=""
+subpackages=""
+
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/ocaml/ocamlbuild/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+
+ make configure OCAML_NATIVE=true \
+ OCAMLBUILD_BINDIR="/usr/bin" \
+ OCAMLBUILD_LIBDIR="/usr/lib/ocaml" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+md5sums="b8c90bac4e54e3b5b8243c4845122dd2 ocamlbuild-0.9.2.tar.gz"
+sha256sums="257a3961da1aa47deb3de8da238ebe1daf13a73efef2228f97a064a90f91c6bc ocamlbuild-0.9.2.tar.gz"
+sha512sums="6f6fa2ca0030256b61a9f93275f26327a032594a1ddd288e1eb9f4c41dfc139e4cdb6cd66ae8e383dd2f8aabb435181abfbf6b4aa0892ef6fa420c29e33b391a ocamlbuild-0.9.2.tar.gz"