aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-amqp
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-03-19 10:06:29 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-06 05:22:32 +0000
commitcd9aa513b588fde6b32fa194edf22812358182ff (patch)
treeedce9a766562ead4fcfa31f8596e60ca4ee0d3c3 /testing/php7-amqp
parent812cca522cc825748fe7790c63af56e54c0acb71 (diff)
downloadaports-cd9aa513b588fde6b32fa194edf22812358182ff.tar.bz2
aports-cd9aa513b588fde6b32fa194edf22812358182ff.tar.xz
testing/php7-amqp: PHP7 AMQP Client
Diffstat (limited to 'testing/php7-amqp')
-rw-r--r--testing/php7-amqp/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-amqp/APKBUILD b/testing/php7-amqp/APKBUILD
new file mode 100644
index 000000000..4ceed3d0a
--- /dev/null
+++ b/testing/php7-amqp/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-amqp
+_pkgreal=amqp
+pkgver=1.7.0
+_pkgver=${pkgver}alpha2
+pkgrel=0
+pkgdesc="Communicate with any AMQP compliant server"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf rabbitmq-c"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="bdd4a68f3a1f21091cc7e67c13cb1a64 amqp-1.7.0alpha2.tgz"
+sha256sums="ce61a679b2899aadfe2f57b7d03b8e8350d29071350df0b141ce85bf20f7c607 amqp-1.7.0alpha2.tgz"
+sha512sums="601e88e4f62b651cde89b3fa792e419362b8cf307623e76763b220c8b81091e8f9073b95365305a730bae4932df7a0639eb02b9e9679d28a39f52278403001b4 amqp-1.7.0alpha2.tgz"