aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-memcached
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-09-29 00:05:15 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-29 00:06:51 +0200
commit5df0e3d4e3587a11e08a78940436ed89418d4034 (patch)
tree42b5f239be9885f43cc2ca5f81ba6e2ab521675a /testing/php7-memcached
parent990bd522239ce3a77ed4b88e039379c32dce89c1 (diff)
downloadaports-5df0e3d4e3587a11e08a78940436ed89418d4034.tar.bz2
aports-5df0e3d4e3587a11e08a78940436ed89418d4034.tar.xz
testing/php7-memcached: improve abuild, remove over-parameterization
Diffstat (limited to 'testing/php7-memcached')
-rw-r--r--testing/php7-memcached/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/php7-memcached/APKBUILD b/testing/php7-memcached/APKBUILD
index 0a7fd857e..f72966ed0 100644
--- a/testing/php7-memcached/APKBUILD
+++ b/testing/php7-memcached/APKBUILD
@@ -1,27 +1,23 @@
# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
pkgname=php7-memcached
-_pkgreal=memcached
-_pkgrepo=php-memcached
-_pkgbranch=php7
-_pkgcommit=583ecd68faec886ac9233277531f78fb6e2043c7
+_pkgname=php-memcached
+_gitrev=583ecd68faec886ac9233277531f78fb6e2043c7
pkgver=3.0_pre20160808
pkgrel=0
pkgdesc="PHP extension for interfacing with memcached via libmemcached library"
-url="https://github.com/$_pkgrepo-dev/$_pkgrepo/tree/$_pkgbranch"
+url="https://github.com/php-memcached-dev/php-memcached"
arch="all"
license="PHP"
depends="php7-session"
pecldepends="php7-dev autoconf zlib-dev"
makedepends="$pecldepends libmemcached-dev cyrus-sasl-dev"
-install=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgrepo-dev/$_pkgrepo/archive/$_pkgcommit.tar.gz"
-
-builddir="$srcdir"/$_pkgrepo-$_pkgcommit
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname-dev/$_pkgname/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$_pkgname-$_gitrev"
build() {
cd "$builddir"
+
phpize7 || return 1
./configure \
--prefix=/usr \
@@ -32,9 +28,10 @@ build() {
package() {
cd "$builddir"
+
make INSTALL_ROOT="$pkgdir/" install || return 1
install -d "$pkgdir"/etc/php7/conf.d || return 1
- echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/20_$_pkgreal.ini
+ echo "extension=memcached.so" > "$pkgdir"/etc/php7/conf.d/20_memcached.ini
}
md5sums="081d43caf5a5cb4f70348280014e3da9 php7-memcached-3.0_pre20160808.tar.gz"