aboutsummaryrefslogtreecommitdiffstats
path: root/testing/prosody
diff options
context:
space:
mode:
authorJesse Young <jlyo@jlyo.org>2011-11-25 12:46:26 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-01 07:15:51 +0000
commitae1967b66eba132dd8c9fa5b5f57712d012b6647 (patch)
treefca1c166178cd340ea41b6d3794cf58c4152f2f4 /testing/prosody
parent379338be8b4cd31b24080f7f01ae14fe124a84ae (diff)
downloadaports-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.bz2
aports-ae1967b66eba132dd8c9fa5b5f57712d012b6647.tar.xz
Replace instances of "--chuid" to "--user" in initd scripts
Fixes #776 Signed-off-by: Jesse Young <jlyo@jlyo.org>
Diffstat (limited to 'testing/prosody')
-rw-r--r--testing/prosody/APKBUILD6
-rw-r--r--testing/prosody/prosody.initd2
2 files changed, 4 insertions, 4 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index 4672f435b..a47078ce3 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=prosody
pkgver=0.8.2
-pkgrel=0
+pkgrel=1
pkgdesc="Lua based Jabber/XMPP server"
url="http://prosody.im/"
arch="all"
@@ -23,7 +23,7 @@ build() {
--with-lua=/usr/bin \
--with-lua-lib=/usr/lib \
--with-lua-include=/usr/include
-
+
make || return 1
}
@@ -41,4 +41,4 @@ package() {
md5sums="6e907bf0d0acf24f1011083020ba6ffb prosody-0.8.2.tar.gz
5a415bb85fb1e00a17cb3ad951e3b889 prosody.cfg.lua.patch
-c0e647e872e30f71fa03faab189ae287 prosody.initd"
+9b68b81deb2148a3a6c3b5d2eb9c96b9 prosody.initd"
diff --git a/testing/prosody/prosody.initd b/testing/prosody/prosody.initd
index 2749d09cf..1a41d4a9e 100644
--- a/testing/prosody/prosody.initd
+++ b/testing/prosody/prosody.initd
@@ -15,7 +15,7 @@ start() {
/usr/bin/prosodyctl start
# start-stop-daemon --start --quiet --background \
# --make-pidfile --pidfile /var/run/${NAME}/${NAME}.pid \
-# --chuid ${USER}:${GROUP} \
+# --user ${USER}:${GROUP} \
# --exec ${DAEMON} -- ${OPTS}
eend $?
}