aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-boto
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-14 23:38:42 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:31:01 +0000
commitca05ea0f3aff143eeb90a4eda95aadc024d6ca74 (patch)
treea7be67eb51ba3688b292010c3fa4106a17c061f9 /testing/py-boto
parent064c9f35cc947da1a133c06cfdd8094b5a2c815c (diff)
downloadaports-ca05ea0f3aff143eeb90a4eda95aadc024d6ca74.tar.bz2
aports-ca05ea0f3aff143eeb90a4eda95aadc024d6ca74.tar.xz
testing/py-boto: new aport
Diffstat (limited to 'testing/py-boto')
-rw-r--r--testing/py-boto/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/py-boto/APKBUILD b/testing/py-boto/APKBUILD
new file mode 100644
index 000000000..00b3fe9d9
--- /dev/null
+++ b/testing/py-boto/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=py-boto
+_pkgname=boto
+pkgver=1.9b
+pkgrel=0
+pkgdesc="An integrated interface to current and future infrastructural services offered by Amazon Web Services."
+url="http://code.google.com/p/boto/"
+arch="x86 x86_64"
+license="MIT"
+depends="python"
+makedepends="python-dev py-setuptools"
+install=
+subpackages="$pkgname-doc"
+source="http://$_pkgname.googlecode.com/files/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+doc() {
+ cd "$_builddir"
+
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
+ install -Dm644 README "$subpkgdir"/usr/share/doc/$pkgname/README
+
+ # Note: The documentation in the 'docs' directory can only be generated
+ # (via sphinx-build from the py-sphinx package) once this package has
+ # been installed. Copying it off for the user.
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/docs
+ cp -R ./docs/* "$subpkgdir"/usr/share/doc/$pkgname/docs/
+ chmod -R 644 "$subpkgdir"/usr/share/doc/$pkgname/docs/
+
+ # Fix subdir perms
+ find "$subpkgdir"/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
+}
+
+md5sums="4fc2fd7b70a971b1363f8465aafe7091 boto-1.9b.tar.gz"