aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-setproctitle
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-03-06 21:46:41 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-07 10:43:38 +0000
commitc63545edb3840f15ef8dabed60f7495334615022 (patch)
tree66413e742eb5bcecd67de39350778723b7c8ac9d /testing/py-setproctitle
parent9c92578b964d32b17eb74065b74a94d108f4a8e0 (diff)
downloadaports-c63545edb3840f15ef8dabed60f7495334615022.tar.bz2
aports-c63545edb3840f15ef8dabed60f7495334615022.tar.xz
testing/py-setproctitle: new aport
https://github.com/dvarrazzo/py-setproctitle A Python module to customize the process title.
Diffstat (limited to 'testing/py-setproctitle')
-rw-r--r--testing/py-setproctitle/APKBUILD41
-rw-r--r--testing/py-setproctitle/spt_status.c.patch10
2 files changed, 51 insertions, 0 deletions
diff --git a/testing/py-setproctitle/APKBUILD b/testing/py-setproctitle/APKBUILD
new file mode 100644
index 000000000..09f760b39
--- /dev/null
+++ b/testing/py-setproctitle/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py-setproctitle
+_pkgname=${pkgname/py-/}
+pkgver="1.1.9"
+pkgrel=0
+pkgdesc="A Python module to customize the process title."
+url="https://github.com/dvarrazzo/py-setproctitle"
+arch="all"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev musl-dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ spt_status.c.patch
+ "
+
+_builddir="$srcdir/$_pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/spt_status.c.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="95d9e56c69437246460a20804961d70d setproctitle-1.1.9.tar.gz
+175429a592de14170499d303a866a2d1 spt_status.c.patch"
+sha256sums="1c3414d18f9cacdab78b0ffd8e886d56ad45f22e55001a72aaa0b2aeb56a0ad7 setproctitle-1.1.9.tar.gz
+6ccc0f3ddbcd5faba5ec8e2b7de88dccd31b04a1797c3ae0454c00ff3c07f839 spt_status.c.patch"
+sha512sums="f5640543105dd039192378983b098e0eca643b5eee314a18886aef0d13674e1ea74f753bfb33582f51a6fb34f9c3d0831764bc099dec9b9e14fe12e7446d30f1 setproctitle-1.1.9.tar.gz
+e15997f0d535801d0aff1ca403a314463892baca06ff1d5ceba2f9f52080016b1945cfa731c4ae4de3fde0649f44ae34ccc40478ef005c8a49d0037382877d4f spt_status.c.patch"
diff --git a/testing/py-setproctitle/spt_status.c.patch b/testing/py-setproctitle/spt_status.c.patch
new file mode 100644
index 000000000..733e30adf
--- /dev/null
+++ b/testing/py-setproctitle/spt_status.c.patch
@@ -0,0 +1,10 @@
+--- a/src/spt_status.c
++++ b/src/spt_status.c
+@@ -55,7 +55,6 @@
+ #endif
+ #ifdef HAVE_SYS_PRCTL_H
+ #include <sys/prctl.h> /* for Linux >= 2.6.9 */
+-#include <linux/prctl.h>
+ #endif
+ #if defined(__darwin__)
+ #include <crt_externs.h>