aboutsummaryrefslogtreecommitdiffstats
path: root/testing/raptor
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/raptor
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/raptor')
-rw-r--r--testing/raptor/APKBUILD46
-rw-r--r--testing/raptor/raptor-curl.patch12
2 files changed, 0 insertions, 58 deletions
diff --git a/testing/raptor/APKBUILD b/testing/raptor/APKBUILD
deleted file mode 100644
index fe3cd52c7..000000000
--- a/testing/raptor/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=raptor
-pkgver=1.4.21
-pkgrel=1
-pkgdesc="RDF parsing/storage backend"
-url="http://www.librdf.org/"
-arch="all"
-license="GPL"
-depends=
-depends_dev="curl-dev libxml2-dev libxslt-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://download.librdf.org/source/raptor-$pkgver.tar.gz
- raptor-curl.patch"
-
-_builddir="$srcdir"/raptor-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="992061488af7a9e2d933df6b694bb876 raptor-1.4.21.tar.gz
-ab48372dcd90a599fb0da73a10830d79 raptor-curl.patch"
diff --git a/testing/raptor/raptor-curl.patch b/testing/raptor/raptor-curl.patch
deleted file mode 100644
index e47a496c4..000000000
--- a/testing/raptor/raptor-curl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/raptor_internal.h b/src/raptor_internal.h
-index f7944db..d9c2068 100644
---- a/src/raptor_internal.h
-+++ b/src/raptor_internal.h
-@@ -852,7 +852,6 @@ int raptor_utf8_is_nfc(const unsigned char *input, size_t length);
-
- #ifdef RAPTOR_WWW_LIBCURL
- #include <curl/curl.h>
--#include <curl/types.h>
- #include <curl/easy.h>
- #endif
-