aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rethinkdb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-07-04 18:02:41 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-07-04 18:02:41 +0000
commit192b0db66f663969e8a1d44b6b957857504f9427 (patch)
tree98a121bf9d817ec4e09b6df2a0e9b04660c97268 /testing/rethinkdb
parentfd734b5b4554dd8b928badc063029e5a842b4ae1 (diff)
downloadaports-192b0db66f663969e8a1d44b6b957857504f9427.tar.bz2
aports-192b0db66f663969e8a1d44b6b957857504f9427.tar.xz
testing/rethinkdb: check for arch
Diffstat (limited to 'testing/rethinkdb')
-rw-r--r--testing/rethinkdb/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/rethinkdb/APKBUILD b/testing/rethinkdb/APKBUILD
index bab967d59..808c68b73 100644
--- a/testing/rethinkdb/APKBUILD
+++ b/testing/rethinkdb/APKBUILD
@@ -41,9 +41,16 @@ build() {
--dynamic all \
--with-system-malloc \
|| return 1
+
+ local _arch
+ case $CARCH in
+ x86) _arch=ia32 ;;
+ x86_64) _arch=x64 ;;
+ esac
+
export LDFLAGS="$LDFLAGS -lexecinfo"
make || paxmark -m \
- build/external/v8_3.30.33.16/build/out/x64.release/mksnapshot
+ build/external/v8_3.30.33.16/build/out/${_arch}.release/mksnapshot
make || return 1
}