aboutsummaryrefslogtreecommitdiffstats
path: root/testing/seahorse
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-16 10:14:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-16 10:14:22 +0000
commit13cd9e4bacf6ec1b2f482e42ad52a98df378ef44 (patch)
tree9354ecd791babaa9d53be8028cc169955624f3be /testing/seahorse
parentcb00129d552b2b3938a652dcbde3e46b75ff5be8 (diff)
downloadaports-13cd9e4bacf6ec1b2f482e42ad52a98df378ef44.tar.bz2
aports-13cd9e4bacf6ec1b2f482e42ad52a98df378ef44.tar.xz
testing/seahorse: new aport
Diffstat (limited to 'testing/seahorse')
-rw-r--r--testing/seahorse/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/seahorse/APKBUILD b/testing/seahorse/APKBUILD
new file mode 100644
index 000000000..43b23b864
--- /dev/null
+++ b/testing/seahorse/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=seahorse
+pkgver=3.20.0
+pkgrel=0
+pkgdesc="GNOME application for managing PGP keys."
+url="http://projects.gnome.org/seahorse/"
+arch="all"
+license="GPL"
+depends="openssh dconf"
+depends_dev=""
+makedepends="$depends_dev vala libxml2-utils
+ yelp-tools intltool itstool gpgme-dev libsoup-dev
+ libsm-dev libsecret-dev gobject-introspection
+ gtk+3.0-dev gcr-dev glib-dev"
+install=""
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="06cdf9805d9d1adddd0140d13f1bd234 seahorse-3.20.0.tar.xz"
+sha256sums="e2b07461ed54a8333e5628e9b8e517ec2b731068377bf376570aad998274c6df seahorse-3.20.0.tar.xz"
+sha512sums="a02d3da7af95256941ef065ac024bd5bfb53a026767b951fa2e26446fb0eed23707e69f72f6e8ebfa7d538823fa41411709fa2bebad4fbd662af1e81bc15ab82 seahorse-3.20.0.tar.xz"