aboutsummaryrefslogtreecommitdiffstats
path: root/testing/znc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-23 13:52:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-23 13:52:11 +0000
commit71d268d109785c42021caeff5ff7a7c075f7f48f (patch)
tree38e631803e162534255169b12309d607ee07a05b /testing/znc
parentfafc60384212a013af177c4c454cce8828124802 (diff)
downloadaports-71d268d109785c42021caeff5ff7a7c075f7f48f.tar.bz2
aports-71d268d109785c42021caeff5ff7a7c075f7f48f.tar.xz
testing/znc: fix iconv configure test
Diffstat (limited to 'testing/znc')
-rw-r--r--testing/znc/APKBUILD13
-rw-r--r--testing/znc/libiconv.patch16
2 files changed, 25 insertions, 4 deletions
diff --git a/testing/znc/APKBUILD b/testing/znc/APKBUILD
index c4e7d3496..5b3ea110c 100644
--- a/testing/znc/APKBUILD
+++ b/testing/znc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=znc
pkgver=0.096
-pkgrel=0
+pkgrel=1
pkgdesc="An advanced IRC bouncer"
url="http://znc.in"
arch="all"
@@ -10,11 +10,12 @@ license="GPLv2"
depends=
depends_dev=
makedepends="perl-dev openssl-dev cyrus-sasl-dev python-dev c-ares-dev swig
- libiconv-dev tcl-dev"
+ libiconv-dev tcl-dev autoconf automake"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-extra $pkgname-modtcl
$pkgname-modperl"
-source="http://znc.in/releases/znc-$pkgver.tar.gz"
+source="http://znc.in/releases/znc-$pkgver.tar.gz
+ libiconv.patch"
_builddir="$srcdir"/znc-$pkgver
prepare() {
@@ -25,10 +26,12 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ aclocal && autoconf || return 1
}
build() {
cd "$_builddir"
+ export CHARSET=
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -72,6 +75,7 @@ extra() {
_mv_mod antiidle.so \
autovoice.so \
block_motd.so \
+ charset.so \
clearbufferonmsg.so \
ctcpflood.so \
droproot.so \
@@ -101,4 +105,5 @@ modperl() {
_mv_mod modperl modperl.so
}
-md5sums="38eec4f1911a68b4d2fc704170e7cbf6 znc-0.096.tar.gz"
+md5sums="38eec4f1911a68b4d2fc704170e7cbf6 znc-0.096.tar.gz
+aafd7f1e87c6fd734cce66281fa2be6e libiconv.patch"
diff --git a/testing/znc/libiconv.patch b/testing/znc/libiconv.patch
new file mode 100644
index 000000000..d986e2f9d
--- /dev/null
+++ b/testing/znc/libiconv.patch
@@ -0,0 +1,16 @@
+--- ./configure.in.orig
++++ ./configure.in
+@@ -366,7 +366,12 @@
+ if test x"$EXTRA" = "xyes"
+ then
+ AC_CHECK_FUNC( iconv, CHARSET=1 )
+- AC_CHECK_LIB( iconv, iconv_open, LIBICONV=-liconv ; CHARSET=1 )
++ dnl On some systems iconv is in a separate library, and may actually
++ dnl be named libiconv.
++ AC_CHECK_LIB( iconv, libiconv_open, LIBICONV=-liconv ; CHARSET=1 )
++ if test $ac_cv_lib_iconv_libiconv = no; then
++ AC_CHECK_LIB( iconv, iconv_open, LIBICONV=-liconv ; CHARSET=1 )
++ fi
+ if test "x$CHARSET" = "x1"
+ then
+ AC_MSG_CHECKING([whether iconv expects a const second argument])