aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2016-11-04 16:13:07 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2016-11-04 16:13:42 +0200
commit22247c38eae490930e43ac46a3881feef936635b (patch)
treef1a9bcb7be412b8a0ed78a6b751c591b1e74a76c /testing
parentb64085f066a5bce4a37b4508cbca1d2b05703061 (diff)
downloadaports-22247c38eae490930e43ac46a3881feef936635b.tar.bz2
aports-22247c38eae490930e43ac46a3881feef936635b.tar.xz
testing/homer-ui: do not remove exec permission from /etc/homer/dashboard
Diffstat (limited to 'testing')
-rw-r--r--testing/homer-ui/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/homer-ui/APKBUILD b/testing/homer-ui/APKBUILD
index e25713a6b..b29b92d29 100644
--- a/testing/homer-ui/APKBUILD
+++ b/testing/homer-ui/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=homer-ui
pkgver=5.0.2
-pkgrel=4
+pkgrel=5
pkgdesc="HOMER User-Interface"
url="https://github.com/sipcapture/homer-ui"
arch="noarch"
@@ -34,7 +34,8 @@ package() {
mkdir -p "$pkgdir"/usr/share/webapps/homer-ui "$pkgdir"/etc/homer
mv "$builddir"/* "$pkgdir"/usr/share/webapps/homer-ui
chown -R :www-data "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard
- chmod -R 664 "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard
+ chmod 775 "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard
+ chmod 664 "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard/*
mv "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard "$pkgdir"/etc/homer/ || return 1
ln -s /etc/homer/dashboard "$pkgdir"/usr/share/webapps/homer-ui/store/dashboard || return 1
}