aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-31 16:30:16 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-31 16:30:22 +0100
commit2641df97b0a4c4bfde4eabd4dbe9ce6aa7f9ab4d (patch)
treefbf80b57c542a3a433bda33461489557fec6a701 /testing
parent17cddfa2011ab1b7ff750cbef1f10ff3e0ed5f0a (diff)
downloadaports-2641df97b0a4c4bfde4eabd4dbe9ce6aa7f9ab4d.tar.bz2
aports-2641df97b0a4c4bfde4eabd4dbe9ce6aa7f9ab4d.tar.xz
testing/mod_auth_cas: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/mod_auth_cas/APKBUILD42
-rw-r--r--testing/mod_auth_cas/remove-error.h.patch10
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/mod_auth_cas/APKBUILD b/testing/mod_auth_cas/APKBUILD
new file mode 100644
index 000000000..c04002c55
--- /dev/null
+++ b/testing/mod_auth_cas/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=mod_auth_cas
+pkgver=1.1
+pkgrel=0
+pkgdesc="An Apache httpd module for integrating with Apereo (JASIG) CAS Server project"
+url="https://www.apereo.org/projects/cas"
+arch="all"
+license="Apache"
+depends=""
+depends_dev=""
+makedepends="$depends_dev apache2-dev curl-dev pcre-dev"
+install=""
+subpackages=""
+source="mod_auth_cas-$pkgver.tar.gz::https://github.com/Jasig/mod_auth_cas/archive/v$pkgver.tar.gz
+ remove-error.h.patch"
+builddir="$srcdir/mod_auth_cas-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ee2e96b71d77fb7bd206d818f0c8a0bc mod_auth_cas-1.1.tar.gz
+d5ca3954d48cd678fd564b1f49de251d remove-error.h.patch"
+sha256sums="e70decc7a887c63df46a848497acdbd8fa4776d0c8a8c1de2c0d71b1b07e3dd0 mod_auth_cas-1.1.tar.gz
+828cbba809503d4feed94d1e1592e16c2c19d030f41cda53179a9bec6dde79c8 remove-error.h.patch"
+sha512sums="39625df051494f55cdbf5d703b0b1f244da6bb4e1a0609869158675c773abcef135e77cef32b70b4e5d5a59f82ea963a95929ae3880e367664e37c8a942c723a mod_auth_cas-1.1.tar.gz
+7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch"
diff --git a/testing/mod_auth_cas/remove-error.h.patch b/testing/mod_auth_cas/remove-error.h.patch
new file mode 100644
index 000000000..82845c6a5
--- /dev/null
+++ b/testing/mod_auth_cas/remove-error.h.patch
@@ -0,0 +1,10 @@
+--- ./src/mod_auth_cas.c.orig
++++ ./src/mod_auth_cas.c
+@@ -22,7 +22,6 @@
+ *
+ */
+
+-#include <error.h>
+ #include <string.h>
+ #include <sys/file.h>
+ #include <sys/types.h>