aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authormellotron <mellotron@tutanota.com>2016-10-18 23:46:39 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-10-30 15:13:38 +0100
commit2a9ec6be775eed4cbb03abe943fb2860a87fc087 (patch)
tree5ebeb022c8373097a9d552800e9b0ad36480f56c /testing
parent0e45808ff272f538ec99dce40ad25c3d7b70482c (diff)
downloadaports-2a9ec6be775eed4cbb03abe943fb2860a87fc087.tar.bz2
aports-2a9ec6be775eed4cbb03abe943fb2860a87fc087.tar.xz
testing/thermald: new aport
https://github.com/01org/thermal_daemon Thermal daemon for IA
Diffstat (limited to 'testing')
-rw-r--r--testing/thermald/APKBUILD46
-rw-r--r--testing/thermald/thermald.initd11
2 files changed, 57 insertions, 0 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
new file mode 100644
index 000000000..030dde9fa
--- /dev/null
+++ b/testing/thermald/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: mellotron <mellotron@tutanota.com>
+# Maintainer:
+pkgname=thermald
+pkgver=1.5.3
+pkgrel=0
+pkgdesc="Thermal daemon for IA"
+url="https://github.com/01org/thermal_daemon"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="autoconf automake libtool dbus-glib-dev libxml2-dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/01org/thermal_daemon/archive/v$pkgver.tar.gz
+ thermald.initd"
+
+builddir="$srcdir/thermal_daemon-$pkgver"
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/etc/init/
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+}
+md5sums="66402236ed3c86a798029cb4d5313817 thermald-1.5.3.tar.gz
+a1e252054ecdc987cf641df912b9a220 thermald.initd"
+sha256sums="e20b450ef27a5b5e45474c831663c8f5ecd14c82ace5a4b1e06c442e0a23b53e thermald-1.5.3.tar.gz
+ec67b3bbdbdb2c65415b061594de7f7e757bea1c2de19f2022d4fac4aba1af26 thermald.initd"
+sha512sums="aab4ade4dc50985cd5d45bcce6ea9b75cce22504eb113c86b8733c8be88a701c8812b8b0f3202f084a8128d50ec794ebe1c73312c0a5a5fd1dbc87eedf02df16 thermald-1.5.3.tar.gz
+c4872ff38e8001b753b12759bcd11364581b12ff710fa1eac21d769fd62cb4ba1a01bd0ba4adec7a72b71be094a425b803239a56296e8c111426e08eb9917c70 thermald.initd"
diff --git a/testing/thermald/thermald.initd b/testing/thermald/thermald.initd
new file mode 100644
index 000000000..ee5eaeb5e
--- /dev/null
+++ b/testing/thermald/thermald.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+
+command=/usr/sbin/thermald
+command_background="yes"
+pidfile="/run/$RC_SVCNAME.pid"
+command_args="--no-daemon --dbus-enable"
+
+depend() {
+ use clock logger
+ need localmount
+}