aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/csync/iconv.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/csync/iconv.patch
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/csync/iconv.patch')
-rw-r--r--unmaintained/csync/iconv.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/unmaintained/csync/iconv.patch b/unmaintained/csync/iconv.patch
new file mode 100644
index 000000000..fcafeb3a8
--- /dev/null
+++ b/unmaintained/csync/iconv.patch
@@ -0,0 +1,26 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc90bc..f8309dd 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -28,7 +28,7 @@ set(CSYNC_LINK_LIBRARIES
+ ${SQLITE3_LIBRARIES}
+ )
+
+-if(HAVE_ICONV AND WITH_ICONV)
++if(WITH_ICONV)
+ list(APPEND CSYNC_PRIVATE_INCLUDE_DIRS ${ICONV_INCLUDE_DIR})
+ list(APPEND CSYNC_LINK_LIBRARIES ${ICONV_LIBRARIES})
+ endif()
+diff --git a/src/std/c_string.c b/src/std/c_string.c
+index f175734..ccc0644 100644
+--- a/src/std/c_string.c
++++ b/src/std/c_string.c
+@@ -39,7 +39,7 @@
+ #include <windows.h>
+ #endif
+
+-#if defined(HAVE_ICONV) && defined(WITH_ICONV)
++#if defined(WITH_ICONV)
+ # ifdef HAVE_ICONV_H
+ # include <iconv.h>
+ # endif