aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/diod
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/diod
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/diod')
-rw-r--r--unmaintained/diod/APKBUILD54
-rwxr-xr-xunmaintained/diod/diod.initd7
2 files changed, 61 insertions, 0 deletions
diff --git a/unmaintained/diod/APKBUILD b/unmaintained/diod/APKBUILD
new file mode 100644
index 000000000..817d43c4d
--- /dev/null
+++ b/unmaintained/diod/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: An2Q ZaVok <an2qzavok@gemail.com>
+# Maintainer:
+pkgname=diod
+pkgver=1.0.24
+pkgrel=2
+pkgdesc="Distributed I/O Daemon - a 9P file server"
+url="http://github.com/chaos/diod"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev attr-dev lua5.1-dev ncurses-dev perl"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/chaos/diod/releases/download/$pkgver/diod-$pkgver.tar.gz
+ diod.initd"
+
+_builddir="$srcdir"/diod-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr/ \
+ --sysconfdir=/etc/diod \
+ --sbindir=/usr/bin \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ ln -s diodmount "$pkgdir"/usr/bin/mount.diod
+ #replacing systemd.service with openrc script
+ rm -rf "$pkgdir/etc/dios/systemd"
+ install -Dm755 "$srcdir"/diod.initd "$pkgdir"/etc/init.d/diod \
+ || return 1
+
+}
+
+md5sums="00566e5d43452b977ddc607181ab2288 diod-1.0.24.tar.gz
+18f81219f1a64ac596ff94e595689d43 diod.initd"
+sha256sums="f41d2b91c1a712132f5457d9d1c3caca985f069bdc8ef27bf4c148ac1d9f8c9f diod-1.0.24.tar.gz
+48d8db2ffc992a2bc8f4d5446e804004932a0050cfd9d6e7b85824474e43b9b6 diod.initd"
+sha512sums="844adc84a2dd705dd94b1103de2a466ae94314d884d8889b6d850a08074d21ac7f5cd40e17ea63ae63cd171adfba3e1601f992d5789709699d74cc8dc8c2c663 diod-1.0.24.tar.gz
+963721cb06a5761101387b869f7513ffcfd2cd0e1b1bb57fb3c987d18827bc4bac6e66556b9ae6c67d3581c04565052aed410513fb2294d1e1fa235bbd7aaf9c diod.initd"
diff --git a/unmaintained/diod/diod.initd b/unmaintained/diod/diod.initd
new file mode 100755
index 000000000..44de6b72d
--- /dev/null
+++ b/unmaintained/diod/diod.initd
@@ -0,0 +1,7 @@
+#!/sbin/runscript
+
+start() {
+ ebegin
+ start-stop-daemon --start -p /var/run/diod.pid -mbx /usr/bin/diod -- -f
+ eend $?
+}