aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/meiga
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/meiga
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/meiga')
-rw-r--r--unmaintained/meiga/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/meiga/APKBUILD b/unmaintained/meiga/APKBUILD
new file mode 100644
index 000000000..ea25106e0
--- /dev/null
+++ b/unmaintained/meiga/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=meiga
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Tool for sharing directories via web"
+url="http://meiga.igalia.com/"
+arch="all"
+license="GPLv2"
+depends=
+makedepends="gtk+-dev libsoup-dev dbus-glib-dev vala gupnp-dev"
+install=
+subpackages=
+source="http://meiga.igalia.com/packages/src/meiga-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="4108c48af075f733c66adcc78dbafa7d meiga-0.4.0.tar.gz"