aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nuttcp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/nuttcp
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/nuttcp')
-rw-r--r--unmaintained/nuttcp/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/nuttcp/APKBUILD b/unmaintained/nuttcp/APKBUILD
new file mode 100644
index 000000000..240af4de5
--- /dev/null
+++ b/unmaintained/nuttcp/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Danilo Godec <danilo.godec@agenda.si>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=nuttcp
+pkgver=7.3.3
+pkgrel=0
+pkgdesc="A network performance measurement tool"
+url="http://www.nuttcp.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-headers"
+install=""
+subpackages=""
+source="http://nuttcp.net/nuttcp/nuttcp-$pkgver/nuttcp-$pkgver.c"
+
+_builddir="$srcdir"/
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ${CC:-gcc} $CFLAGS -o nuttcp $LDFLAGS "$srcdir"/nuttcp-$pkgver.c
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 nuttcp "$pkgdir"/usr/sbin/nuttcp
+}
+md5sums="dfbff3c38fb0cbdc474ca6d13539d425 nuttcp-7.3.3.c"
+sha256sums="d68e291a72375d76f301d54aa945727c95e78090aa6783a4844764e632e98a4a nuttcp-7.3.3.c"
+sha512sums="1df425743868c0f1f502b9bdff8d9644a0d298d59b9c543d9023551598ab6dd0547d6492bc09dd1cc4b136b22495ce2b17d1ebe354387785f71e22cda5466f11 nuttcp-7.3.3.c"