aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nvme-cli
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/nvme-cli
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/nvme-cli')
-rw-r--r--unmaintained/nvme-cli/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/nvme-cli/APKBUILD b/unmaintained/nvme-cli/APKBUILD
new file mode 100644
index 000000000..760b69c87
--- /dev/null
+++ b/unmaintained/nvme-cli/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Florian Heigl <florian.heigl@gmail.com>
+# Maintainer: Florian Heigl <florian.heigl@gmail.com>
+pkgname=nvme-cli
+pkgver=0.3
+pkgrel=1
+pkgdesc="NVM-Express user space tooling for Linux"
+arch="all"
+url="https://github.com/linux-nvme/nvme-cli"
+license="GPL"
+depends=""
+makedepends="$depends_dev linux-headers"
+provides="nvme-cli"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/linux-nvme/nvme-cli/archive/v${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+# no patches just yet
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX="/usr" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}
+
+md5sums="397445255b73a1159d3000974d38a098 nvme-cli-0.3.tar.gz"
+sha256sums="c631e90dd4d411cdb618b26bc36b06706e6f1f2d3db38874bcfe48f4bc15aac4 nvme-cli-0.3.tar.gz"
+sha512sums="91e85eb487991da24cb254abf0047004ab21bcc2be18a569a86476eac80ac7e0a677daebb1c157b5bc00a3518df728d65f66da0b20e240e1fd786b655a791045 nvme-cli-0.3.tar.gz"