aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/php-rrd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/php-rrd
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/php-rrd')
-rw-r--r--unmaintained/php-rrd/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/unmaintained/php-rrd/APKBUILD b/unmaintained/php-rrd/APKBUILD
new file mode 100644
index 000000000..ba235d7fe
--- /dev/null
+++ b/unmaintained/php-rrd/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Diaz Devera Victor <vitronic2@gmail.com>
+pkgname=php-rrd
+_pkgreal=rrd
+pkgver=1.1.3
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP extension that provides bindings to rrd tool system"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php-dev autoconf"
+makedepends="$pecldepends rrdtool-dev"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php/conf.d/$_pkgreal.ini
+}
+
+md5sums="bde6c50fa2aa39090ed22e574ac71c5a rrd-1.1.3.tgz"
+sha256sums="0415ac51e09fe2e7a999d155d10d6af42ddf40ab0b4847a63ed1f9458533858e rrd-1.1.3.tgz"
+sha512sums="356264de1b967af0f78e25e3c0afcbec704dd3e49d828e08d21d744d5fcdc46f4cd7f7c118b4e283c20bcaf2a4c29e0ac9437c7f66ca0d260a76fddf7b9d3242 rrd-1.1.3.tgz"