aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/tc-play
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/tc-play
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/tc-play')
-rw-r--r--unmaintained/tc-play/APKBUILD48
-rw-r--r--unmaintained/tc-play/libsuffix.patch24
2 files changed, 72 insertions, 0 deletions
diff --git a/unmaintained/tc-play/APKBUILD b/unmaintained/tc-play/APKBUILD
new file mode 100644
index 000000000..76fa7f846
--- /dev/null
+++ b/unmaintained/tc-play/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=tc-play
+pkgver=2.0
+pkgrel=0
+pkgdesc="Free and simple TrueCrypt Implementation based on dm-crypt"
+url="https://github.com/bwalex/tc-play"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libgcrypt-dev cmake lvm2-dev util-linux-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="tc-play-$pkgver.tar.gz::https://github.com/bwalex/tc-play/archive/v$pkgver.tar.gz
+ libsuffix.patch"
+
+_builddir="$srcdir"/tc-play-$pkgver
+prepare() {
+ local i
+ mkdir -p "$_builddir"/objdir
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"/objdir
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/objdir
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="c0c6638f078d946b58d6108518e54e3c tc-play-2.0.tar.gz
+0d44056b83c9a0db59d0eec530b878e3 libsuffix.patch"
+sha256sums="0e17890f37e862746364b10bad62bbd9f3e2b2811a24b07df12eff266534e42d tc-play-2.0.tar.gz
+4891905a1650df46004820dddd00f53b7d9790cf56410438e737e19e9b337cf4 libsuffix.patch"
+sha512sums="17408b2a664eb6822c77ede4f38ca67cdf643512014619d830a2c024bb8971811eded4edd65f6398d6112a3b57cd11a5b414357878c817c9cc2aac9d851946d7 tc-play-2.0.tar.gz
+4e1c8566f1dee3a8fdeb29f1ac0164b69ff0095cc13ceb339aeceea4b7db63abcea11579ca4613cd9998550cba44cbf0ac08a5386131db9cbd3a663e9bd476f6 libsuffix.patch"
diff --git a/unmaintained/tc-play/libsuffix.patch b/unmaintained/tc-play/libsuffix.patch
new file mode 100644
index 000000000..31f1e22d3
--- /dev/null
+++ b/unmaintained/tc-play/libsuffix.patch
@@ -0,0 +1,24 @@
+--- ./CMakeLists.txt.orig
++++ ./CMakeLists.txt
+@@ -63,21 +63,6 @@
+ endif()
+
+
+-if (NOT LIB_SUFFIX)
+- message(STATUS "")
+- message(STATUS "LIB_SUFFIX variable is not defined. It will be autodetected now.")
+- message(STATUS "You can set it manually with -DLIB_SUFFIX=<value> (e.g. 64).")
+- if (CMAKE_SIZEOF_VOID_P EQUAL 8)
+- message(STATUS "\nSetting LIB_SUFFIX=64\n")
+- set (LIB_SUFFIX "64")
+- else()
+- message(STATUS "\nSetting LIB_SUFFIX=\n")
+- set (LIB_SUFFIX "")
+- endif()
+-endif()
+-
+-
+-
+ add_executable(tcplay-bin main.c ${SRCS_COMMON} ${SRCS_LINUX} ${SRCS_PBKDF})
+ set_target_properties(tcplay-bin PROPERTIES OUTPUT_NAME tcplay)
+ set_target_properties(tcplay-bin PROPERTIES COMPILE_FLAGS "${CFLAGS_COMMON} ${DEVMAPPER_CFLAGS} ${UUID_CFLAGS} ${GCRYPT_CFLAGS}")