aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/yum
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/yum
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/yum')
-rw-r--r--unmaintained/yum/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/yum/APKBUILD b/unmaintained/yum/APKBUILD
new file mode 100644
index 000000000..50c472c49
--- /dev/null
+++ b/unmaintained/yum/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+
+pkgname=yum
+pkgver=3.4.3
+pkgrel=1
+pkgdesc='Advanced front-end for rpm'
+arch=noarch
+license='GPL'
+url='http://yum.baseurl.org'
+depends='python py-urlgrabber py-pysqlite yum-metadata-parser py-iniparse py-rpm rpm'
+makedepends='intltool'
+subpackages="$pkgname-doc $pkgname-lang"
+source="$url/download/3.4/yum-$pkgver.tar.gz"
+
+build() {
+ make -C "$srcdir"/$pkgname-$pkgver || return 1
+}
+
+package() {
+ make -C "$srcdir"/$pkgname-$pkgver DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/etc/rc.d
+}
+
+md5sums="7c8ea8beba5b4e7fe0c215e4ebaa26ed yum-3.4.3.tar.gz"
+sha256sums="0178f97820ced9bfbcc269e6fc3ea35e29e35e2d263d24c7bff8660ee62d37ca yum-3.4.3.tar.gz"
+sha512sums="e72f83ba090ba7453a78954437dd14b8f818302464d0a278b60c2c5e0530684db0cece60cb30fce85d8014034c857da3696e1e51e08fddde39be66f3ad1eb817 yum-3.4.3.tar.gz"