aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/zathura
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/zathura
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/zathura')
-rw-r--r--unmaintained/zathura/APKBUILD45
-rw-r--r--unmaintained/zathura/without-synctex.patch53
2 files changed, 98 insertions, 0 deletions
diff --git a/unmaintained/zathura/APKBUILD b/unmaintained/zathura/APKBUILD
new file mode 100644
index 000000000..33733e72d
--- /dev/null
+++ b/unmaintained/zathura/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=zathura
+pkgver=0.3.4
+pkgrel=0
+pkgdesc="Document viewer with Vim-like controls"
+url="https://pwmt.org/projects/$pkgname"
+arch="all"
+license="zlib"
+depends=""
+depends_dev=""
+makedepends="girara-dev gtk+3.0-dev glib-dev file-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://pwmt.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
+ without-synctex.patch"
+
+_builddir="$srcdir"/zathura-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="64a19c0a78d06e3a8c2098911d59b072 zathura-0.3.4.tar.gz
+cf64a40358d705cee2d8174498d56e9f without-synctex.patch"
+sha256sums="52c4a3efc5843ce7c720ea7357667699363c809fd34ada4cb350d0e1031d0234 zathura-0.3.4.tar.gz
+e6cb2e825c584a82283a580fdd77428e91321f46d929eff42979e858eb9eac81 without-synctex.patch"
+sha512sums="663a24574838fe6531bf588ec97ed54f3bf3601c6ed11bbcd38347e8fa1876c4cfa964ab7bba70f8afd40dd9d984315b0966546394c0efac00c6fbd9967b77a2 zathura-0.3.4.tar.gz
+e750c8b2d7de3fdfe8275fe3c625bce6d3d9c12a956d0ea56a0af6848ecdd8cd903ba363fcff829024adc493b8c4f4b271f9f1d6dee52a3b14405df9b42b0ee0 without-synctex.patch"
diff --git a/unmaintained/zathura/without-synctex.patch b/unmaintained/zathura/without-synctex.patch
new file mode 100644
index 000000000..b12ca3117
--- /dev/null
+++ b/unmaintained/zathura/without-synctex.patch
@@ -0,0 +1,53 @@
+From 5b3c183a9f8edf778f405f5da9b1ef8384775852 Mon Sep 17 00:00:00 2001
+From: Jan Palus <jan.palus@gmail.com>
+Date: Mon, 28 Dec 2015 22:19:07 +0100
+Subject: [PATCH] fix build without synctex
+
+---
+ zathura/main.c | 19 ++++++++++++-------
+ 1 file changed, 12 insertions(+), 7 deletions(-)
+
+diff --git a/zathura/main.c b/zathura/main.c
+index 060382a..3278dbe 100644
+--- zathura/main.c
++++ zathura/main.c
+@@ -84,12 +84,14 @@ run_synctex_forward(const char* synctex_fwd, const char* filename,
+
+ static zathura_t*
+ init_zathura(const char* config_dir, const char* data_dir,
+- const char* cache_dir, const char* plugin_path, char** argv,
++ const char* cache_dir, const char* plugin_path, char** argv
++#ifdef WITH_SYNCTEX
++ , char* synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+- char* synctex_editor, Window embed)
+-#else
+- char* synctex_editor)
++ , Window embed
+ #endif
++ )
+ {
+ /* create zathura session */
+ zathura_t* zathura = zathura_create();
+@@ -250,11 +252,14 @@ main(int argc, char* argv[])
+
+ /* Create zathura session */
+ zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir,
++ plugin_path, argv
++#ifdef WITH_SYNCTEX
++ , synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+- plugin_path, argv, synctex_editor, embed);
+-#else
+- plugin_path, argv, synctex_editor);
++ , embed
+ #endif
++ );
+ if (zathura == NULL) {
+ girara_error("Could not initialize zathura.");
+ return -1;
+--
+libgit2 0.23.3
+