aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/openrc/0001-Fix-s-and-S.patch25
-rw-r--r--main/openrc/0001-Force-root-be-rw-before-localmount.patch26
-rw-r--r--main/openrc/APKBUILD10
-rw-r--r--main/openrc/localmount.patch12
4 files changed, 58 insertions, 15 deletions
diff --git a/main/openrc/0001-Fix-s-and-S.patch b/main/openrc/0001-Fix-s-and-S.patch
new file mode 100644
index 000000000..1d3536d6f
--- /dev/null
+++ b/main/openrc/0001-Fix-s-and-S.patch
@@ -0,0 +1,25 @@
+From 4d86d346354543f27058923587dd25f8c460363c Mon Sep 17 00:00:00 2001
+From: Roy Marples <roy@marples.name>
+Date: Fri, 26 Mar 2010 22:10:03 +0000
+Subject: [PATCH] Fix -s and -S.
+
+---
+ src/rc/rc.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/rc/rc.c b/src/rc/rc.c
+index 6d04b3d..ccafbe3 100644
+--- a/src/rc/rc.c
++++ b/src/rc/rc.c
+@@ -773,7 +773,7 @@ handle_bad_signal(int sig)
+ #endif
+
+ #include "_usage.h"
+-#define getoptstring "o:" getoptstring_COMMON
++#define getoptstring "o:s:S" getoptstring_COMMON
+ static const struct option longopts[] = {
+ { "override", 1, NULL, 'o' },
+ { "service", 1, NULL, 's' },
+--
+1.7.3.4
+
diff --git a/main/openrc/0001-Force-root-be-rw-before-localmount.patch b/main/openrc/0001-Force-root-be-rw-before-localmount.patch
new file mode 100644
index 000000000..3381d9f0d
--- /dev/null
+++ b/main/openrc/0001-Force-root-be-rw-before-localmount.patch
@@ -0,0 +1,26 @@
+From c92e702f6dddab58a749f5fea5479ff2affeb498 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 21 Dec 2010 10:29:37 +0000
+Subject: [PATCH] Force root be rw before localmount
+
+The service that pulls in root remount is mtab which we dont need/use.
+---
+ init.d/localmount.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/init.d/localmount.in b/init.d/localmount.in
+index a4d1116..2895894 100644
+--- a/init.d/localmount.in
++++ b/init.d/localmount.in
+@@ -6,7 +6,7 @@ description="Mounts disks and swap according to /etc/fstab."
+
+ depend()
+ {
+- need fsck
++ need fsck root
+ use lvm modules mtab
+ keyword -jail -openvz -prefix -vserver -lxc
+ }
+--
+1.7.3.4
+
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index 4e96b4bb8..5f8923635 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openrc
pkgver=0.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://roy.marples.name/openrc"
arch="x86 x86_64"
@@ -11,7 +11,10 @@ subpackages="$pkgname-doc $pkgname-dev"
install="$pkgname.post-install $pkgname.post-upgrade"
source="http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2
openrc-0.4.3-mkmntdirs.patch
- localmount.patch
+
+ 0001-Fix-s-and-S.patch
+ 0001-Force-root-be-rw-before-localmount.patch
+
hostname.initd
hwdrivers.initd
keymaps.initd
@@ -58,7 +61,8 @@ package() {
md5sums="90aa095508b0e92b06eda43b641cba49 openrc-0.6.1.tar.bz2
8c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch
-fa1809cd59cc0559a163bc6adc7398f6 localmount.patch
+cb4b6e0f378600cbdbb58e905e9cab26 0001-Fix-s-and-S.patch
+4fd036ff07ed9ad7fb76af6a3ffc0695 0001-Force-root-be-rw-before-localmount.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
b1e64885f301166df30be3e3cf5338ff hwdrivers.initd
33ca3e558c42cdd17adccbc7807298f7 keymaps.initd
diff --git a/main/openrc/localmount.patch b/main/openrc/localmount.patch
deleted file mode 100644
index c80d640a2..000000000
--- a/main/openrc/localmount.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru openrc-0.5.0.orig/init.d/localmount.in openrc-0.5.0/init.d/localmount.in
---- openrc-0.5.0.orig/init.d/localmount.in 2009-10-09 09:08:43.000000000 +0000
-+++ openrc-0.5.0/init.d/localmount.in 2009-10-09 09:09:08.000000000 +0000
-@@ -31,7 +31,7 @@
- {
- # We never unmount / or /dev or $RC_SVCDIR
- local x= no_umounts_r="/|/dev|/dev/.*|${RC_SVCDIR}"
-- no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec"
-+ no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec|/.modloop"
- # RC_NO_UMOUNTS is an env var that can be set by plugins
- OIFS=$IFS SIFS=${IFS-y}
- IFS=$IFS: