aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-stringy/link-to-correct-lua-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-stringy/link-to-correct-lua-version.patch')
-rw-r--r--main/lua-stringy/link-to-correct-lua-version.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/main/lua-stringy/link-to-correct-lua-version.patch b/main/lua-stringy/link-to-correct-lua-version.patch
new file mode 100644
index 000000000..e7ecc5d36
--- /dev/null
+++ b/main/lua-stringy/link-to-correct-lua-version.patch
@@ -0,0 +1,19 @@
+--- lua-projects-0.4/stringy/Makefile
++++ lua-projects-0.4.libs/stringy/Makefile
+@@ -1,6 +1,7 @@
+ LUA ?= lua5.1
+ LUA_PC ?= lua5.1
+ LUA_CFLAGS = $(shell pkg-config $(LUA_PC) --cflags)
++LUA_LDFLAGS = $(shell pkg-config $(LUA_PC) --libs)
+
+ CFLAGS ?= -O3 -Wall -Werror
+
+@@ -12,7 +13,7 @@
+ stringy.o: fastsearch.h
+
+ stringy.so: stringy.o stringy_test.lua
+- $(CC) -shared stringy.o -o $@
++ $(CC) -shared $(LUA_LDFLAGS) stringy.o -o $@
+ $(LUA) stringy_test.lua
+
+ clean: