aboutsummaryrefslogtreecommitdiffstats
path: root/main/smstools/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/smstools/makefile.patch')
-rw-r--r--main/smstools/makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/smstools/makefile.patch b/main/smstools/makefile.patch
new file mode 100644
index 000000000..459e5d64a
--- /dev/null
+++ b/main/smstools/makefile.patch
@@ -0,0 +1,42 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -7,7 +7,7 @@
+ VERSION=$(shell grep package_version src/version.h | cut -f2)
+
+ compile:
+- cd src && $(MAKE) -$(MAKEFLAGS)
++ cd src && $(MAKE)
+
+ install: compile
+ ./install.sh $(BINDIR)
+@@ -16,7 +16,7 @@
+ ./uninstall.sh $(BINDIR)
+
+ clean:
+- cd src && $(MAKE) -$(MAKEFLAGS) clean
++ cd src && $(MAKE) clean
+
+ package: compile clean
+ ./package.sh
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -37,15 +37,15 @@
+ # Use the following only on GNU/Linux and only if you need ps listing like "smsd: MAINPROCESS" and "smsd: GSM1"
+ # CFLAGS += -D USE_LINUX_PS_TRICK
+
+-all: smsd
+-
+-smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+-
+ ifneq (,$(findstring SOLARIS,$(CFLAGS)))
+ ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
+ override LFLAGS += -lsocket -lnsl
+ endif
+ endif
++
++all: smsd
++
++smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+
+ ifneq (,$(findstring NOSTATS,$(CFLAGS)))
+ $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)