aboutsummaryrefslogtreecommitdiffstats
path: root/main/vlc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/vlc/APKBUILD')
-rw-r--r--main/vlc/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index 53a627b7a..373e70385 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
pkgver=1.1.7
-pkgrel=3
+pkgrel=6
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
url="http://www.videolan.org/vlc/"
arch="all"
@@ -46,7 +46,9 @@ makedepends="
mesa-dev
pkgconfig
sdl-dev
+ speex-dev
sysfsutils-dev
+ taglib-dev
v4l-utils-dev
x264-dev
"
@@ -78,7 +80,7 @@ build ()
cd "$_builddir"
sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
- export CFLAGS="$CFLAGS -D_GNU_SOURCE -fPIC"
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure --prefix=/usr \
--disable-mmx \
@@ -88,6 +90,7 @@ build ()
--disable-rpath \
--enable-a52 \
--enable-avcodec \
+ --enable-avformat \
--enable-dbus \
--enable-dbus-control \
--enable-dvbpsi \
@@ -99,7 +102,9 @@ build ()
--enable-ncurses \
--enable-realrtsp \
--enable-sdl \
+ --enable-speex \
--enable-sout \
+ --enable-taglib \
--enable-theora \
--enable-v4l \
--enable-v4l2 \
@@ -124,15 +129,12 @@ build ()
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir"/ install || return 1
+ make DESTDIR="$pkgdir" install || return 1
# for res in 16 32 48 128; do
# install -D -m644 share/vlc${res}x${res}.png \
# "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
# done
rm -rf "$pkgdir"/usr/lib/mozilla
-# FIXME: for some reason libavcodec_plugin does not get installed
- install -m644 $_builddir/modules/codec/avcodec/.libs/libavcodec_plugin.so \
- $pkgdir/usr/lib/vlc/plugins/codec/libavcodec_plugin.so
}
_mv() {
@@ -149,7 +151,7 @@ xorg() {
cd "$pkgdir"
for i in $(find -type f ); do
if ldd $i 2>/dev/null | grep -q libX; then
- _mv "$i" || return 1
+ echo $i | grep libavcodec_plugin.so || _mv "$i" || return 1
fi
done