aboutsummaryrefslogtreecommitdiffstats
path: root/testing/freeradius3/disable-cert-generation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/freeradius3/disable-cert-generation.patch')
-rw-r--r--testing/freeradius3/disable-cert-generation.patch28
1 files changed, 9 insertions, 19 deletions
diff --git a/testing/freeradius3/disable-cert-generation.patch b/testing/freeradius3/disable-cert-generation.patch
index 771787dc3..900c44622 100644
--- a/testing/freeradius3/disable-cert-generation.patch
+++ b/testing/freeradius3/disable-cert-generation.patch
@@ -1,14 +1,14 @@
--- a/Makefile
+++ b/Makefile
-@@ -28,7 +28,6 @@
- # Run "radiusd -C", looking for errors.
- #
- $(BUILD_DIR)/tests/radiusd-c: ${BUILD_DIR}/bin/radiusd | build.raddb
+@@ -40,7 +40,6 @@
+ # Only redirect STDOUT, which should contain details of why the test failed.
+ # Don't molest STDERR as this may be used to receive output from a debugger.
+ $(BUILD_DIR)/tests/radiusd-c: raddb/test.conf ${BUILD_DIR}/bin/radiusd | build.raddb
- @$(MAKE) -C raddb/certs
- @if ! ./build/make/jlibtool --mode=execute ./build/bin/radiusd -XCMd ./raddb -n debug -D ./share > $(BUILD_DIR)/tests/radiusd.config.log 2>&1; then \
- cat $(BUILD_DIR)/tests/radiusd.config.log; \
- echo "FAIL: radiusd -C"; \
-@@ -205,13 +204,6 @@
+ @printf "radiusd -C... "
+ @if ! ./build/make/jlibtool --mode=execute ./build/bin/radiusd -XCMd ./raddb -D ./share -n test > $(BUILD_DIR)/tests/radiusd.config.log; then \
+ @rm -f raddb/test.conf; \
+@@ -224,13 +223,6 @@
.PHONY: TAGS
TAGS:
etags `find src -type f -name '*.[ch]' -print` > $@
@@ -18,17 +18,7 @@
-#
-.PHONY: certs
-certs:
-- @cd raddb/certs && $(MAKE)
+- @$(MAKE) -C raddb/certs
######################################################################
#
---- a/raddb/all.mk
-+++ b/raddb/all.mk
-@@ -114,7 +114,6 @@
-
- $(LOCAL_CERT_PRODUCTS):
- @echo BOOTSTRAP raddb/certs/
-- @$(MAKE) -C $(R)$(raddbdir)/certs/
-
- # Bootstrap is special
- $(R)$(raddbdir)/certs/bootstrap: | raddb/certs/bootstrap $(LOCAL_CERT_PRODUCTS)