aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hplip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hplip/APKBUILD')
-rw-r--r--testing/hplip/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
new file mode 100644
index 000000000..fd18dd4c5
--- /dev/null
+++ b/testing/hplip/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+
+pkgname=hplip
+pkgver=3.16.10
+pkgrel=0
+pkgdesc="Drivers for HP printers"
+arch=all
+url="http://hplipopensource.com"
+license="GPL"
+depends="python py-dbus"
+makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev python-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-includes.patch
+ disable_upgrade.patch"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --disable-qt4 \
+ --disable-scan-build \
+ --disable-fax-build \
+ --disable-dbus-build \
+ --enable-cups-ppd-install \
+ --enable-foomatic-ppd-install \
+ --enable-foomatic-drv-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ make -j1 -C "$builddir" DESTDIR="$pkgdir" install || return 1
+ cd "$pkgdir"
+ rm -rf etc/sane.d etc/xdg usr/share/hal etc/init.d etc/udev
+}
+
+md5sums="dd3bf0ecd410e6961abd86407b7f802f hplip-3.16.10.tar.gz
+a9cd9a64bc4e1ba14ef221efdcb0d940 fix-includes.patch
+65bddd5951bd2d12a26bbf7b51bcab27 disable_upgrade.patch"
+sha256sums="45b44e0334f76069511b0b2a40885a12d055013bc95a62250de5d1abc10dee84 hplip-3.16.10.tar.gz
+9a1d8b509d7bcacb03895529e3c6c83704ea784444bf0deae75ac59feb9e32b2 fix-includes.patch
+b3f8d91a07216e6aad4dbfdb79ae19496b03c29f56444059b9b93a32c86ceb8e disable_upgrade.patch"
+sha512sums="2aa8cdd7ec0aa042f4c159f4db6bf80e0cc4ffd30f060814d44fcce2f2800dc0195c26ccc6f8d10dc9c62b3fcbc0befcf68f3ad6a5a81f63ab6a26a25686bbad hplip-3.16.10.tar.gz
+173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498 fix-includes.patch
+57e14c581e82a0dd44344524dc4eb4d845843cf0775b60475541cabfb9d67a4fdab501be3977f8ca9888fbbee4d0392e6068c788e7a85cf4c1add5848be21ae7 disable_upgrade.patch"