aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jhead
diff options
context:
space:
mode:
Diffstat (limited to 'testing/jhead')
-rw-r--r--testing/jhead/APKBUILD41
-rw-r--r--testing/jhead/makefile-destdir.patch17
2 files changed, 58 insertions, 0 deletions
diff --git a/testing/jhead/APKBUILD b/testing/jhead/APKBUILD
new file mode 100644
index 000000000..961b59d6c
--- /dev/null
+++ b/testing/jhead/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=jhead
+pkgver=2.93
+pkgrel=0
+pkgdesc="An Exif jpeg header manipulation tool"
+url="http://www.sentex.net/~mwandel/jhead/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.sentex.net/~mwandel/$pkgname/$pkgname-$pkgver.tar.gz
+ makefile-destdir.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="23ac51b4aea2df663d684744e282eb7d jhead-2.93.tar.gz
+c0daea2a99f121ea84adb2fce47e0a4e makefile-destdir.patch"
diff --git a/testing/jhead/makefile-destdir.patch b/testing/jhead/makefile-destdir.patch
new file mode 100644
index 000000000..d9c5b1a0b
--- /dev/null
+++ b/testing/jhead/makefile-destdir.patch
@@ -0,0 +1,17 @@
+--- jhead-2.93/makefile
++++ jhead-2.93/makefile.new
+@@ -4,6 +4,7 @@
+ OBJ=.
+ SRC=.
+ CFLAGS= -O3 -Wall
++prefix= /usr
+
+ all: jhead
+
+@@ -20,4 +21,5 @@
+ rm -f $(objs) jhead
+
+ install:
+- cp jhead ${DESTDIR}/usr/local/bin/
++ install -Dp -m 0755 jhead $(DESTDIR)$(prefix)/bin/jhead
++ install -m644 -D jhead.1 $(DESTDIR)$(prefix)/share/man/man1/jhead.1