aboutsummaryrefslogtreecommitdiffstats
path: root/testing/numix-themes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/numix-themes/APKBUILD')
-rw-r--r--testing/numix-themes/APKBUILD68
1 files changed, 0 insertions, 68 deletions
diff --git a/testing/numix-themes/APKBUILD b/testing/numix-themes/APKBUILD
deleted file mode 100644
index 16d3c941a..000000000
--- a/testing/numix-themes/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=numix-themes
-_pkgname=numix-gtk-theme
-pkgver=2.6.1
-pkgrel=0
-pkgdesc="A modern flat theme with a combination of light and dark elements, GTK 2 and 3"
-url="http://shimmerproject.org/project/Numix/"
-arch="noarch"
-license="GPLv3"
-makedepends="$depends_dev"
-subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4 $pkgname-xfce4-notifyd:_notify
- $pkgname-openbox:_openbox"
-source="numix-$pkgver.tar.gz::https://github.com/numixproject/$_pkgname/archive/$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- # Remove Unity theme
- rm -f gtk-3.0/apps/unity.css
- sed -i '/unity\.css/d' gtk-3.0/gtk.css
- rm -rf unity
-}
-
-package() {
- cd "$_builddir"
- mkdir -p "$pkgdir"/usr/share/themes/Numix
- cp -pr * "$pkgdir"/usr/share/themes/Numix
- rm -f "$pkgdir"/usr/share/themes/Numix/Makefile
-}
-
-_mv() {
- pkgdesc="$1"
- install_if="$pkgname=$pkgver-r$pkgrel $2";
- depends=
- local _i
- shift; shift
- mkdir -p "$subpkgdir"/usr/share/themes/Numix
- for _i; do
- msg "moving $_i"
- mv "$pkgdir"/usr/share/themes/Numix/$_i \
- "$subpkgdir"/usr/share/themes/Numix || return 1
- done
-}
-
-gtk2() {
- _mv "Numix GTK2 themes" gtk2.0 gtk-2.0
- depends="gtk-murrine-engine"
-}
-
-gtk3() { _mv "Numix GTK3 themes" gtk3.0 gtk-3.*; }
-metacity() { _mv "Numix Metacity themes" metacity metacity-1; }
-xfwm4() { _mv "Numix Xfce4 themes" xfwm4 xfwm4; }
-_notify() { _mv "Numix Xfce4-notifyd themes" xfce4-notifyd xfce-notify-4.0; }
-_openbox() { _mv "Numix openbox themes" openbox openbox-3; }
-
-md5sums="499e2e8e9d7d1d81403ebf8f65c8ced6 numix-2.6.1.tar.gz"
-sha256sums="7d81fb0fe7a50f933ae8016154a6da8ea4f6c12d988f735db277424af344a5bf numix-2.6.1.tar.gz"
-sha512sums="ebdbf20049b84141b10bafa93685f844b59ae629d19ede0eef44afafa18357cb54d66cb830a67bf09ab251b04dbf21193e7bc5ea19124061d7fd8dbf4538a745 numix-2.6.1.tar.gz"