aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-bottle')
-rw-r--r--testing/py-bottle/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/py-bottle/APKBUILD b/testing/py-bottle/APKBUILD
index d299e629b..29484943d 100644
--- a/testing/py-bottle/APKBUILD
+++ b/testing/py-bottle/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Paul Kilar <pkilar@gmail.com>
# Maintainer: Paul Kilar <pkilar@gmail.com>
pkgname=py-bottle
-pkgver='0.11.6'
+_pkgname=bottle
+pkgver=0.11.6
pkgrel=0
-pkgdesc="Bottle is a fast, simple and lightweight WSGI micro web-framework for Python."
+pkgdesc="A fast, simple and lightweight WSGI micro web-framework"
url="http://bottlepy.org/"
arch="noarch"
license="MIT"
@@ -12,9 +13,9 @@ depends_dev=""
makedepends=""
install=""
subpackages=""
-source="https://pypi.python.org/packages/source/b/bottle/bottle-$pkgver.tar.gz"
-_builddir="$srcdir"/bottle-$pkgver
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -34,6 +35,7 @@ package() {
cd "$_builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
+
md5sums="0bafdc4e13ea2b1a3bddf36b5af108c4 bottle-0.11.6.tar.gz"
sha256sums="2e63802cbe6a21537e35d92ec3c80a1e302dc619d169efe6a212cab9f48e7b29 bottle-0.11.6.tar.gz"
sha512sums="511748cee1694db9ec04f5f49cf5d44d273f6424733532d4558acc546b4a44a1462433ca9483bf59235b48318b20289e9ae8f8c5d1dc4379da4a86c03848f922 bottle-0.11.6.tar.gz"