aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/madwimax/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/madwimax/APKBUILD')
-rw-r--r--unmaintained/madwimax/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/madwimax/APKBUILD b/unmaintained/madwimax/APKBUILD
new file mode 100644
index 000000000..a06da00cd
--- /dev/null
+++ b/unmaintained/madwimax/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sergey
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=madwimax
+pkgver=0.1.1
+pkgrel=4
+pkgdesc="WiMAX driver for the Samsung SWC-U200 and similar USB modems"
+url="http://code.google.com/p/madwimax/"
+arch="all"
+license="GPL2"
+depends=
+makedepends="libusb-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://madwimax.googlecode.com/files/madwimax-0.1.1.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --without-man-pages \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+#2009-10-07,SP: you can start it simply by /usr/sbin/madwimax -d
+#, so no init.d script so far...
+
+}
+
+md5sums="4ebd2d74e887e6f9d6f23067a4ad8272 madwimax-0.1.1.tar.gz"