summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-03-01 18:10:30 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:35:09 +0000
commit561d5c2c61a98a3240b0907720143a82d62bf373 (patch)
treeb00f303e7bc16f78ebd164d5c7c4ead14b29d037
parentc706017296ad948c513d8422dec5faaa4d935dcc (diff)
downloadaports-fcolista-561d5c2c61a98a3240b0907720143a82d62bf373.tar.bz2
aports-fcolista-561d5c2c61a98a3240b0907720143a82d62bf373.tar.xz
testing/py-genshi: new aport
Genshi is a Python library that provides an integrated set of components for parsing, generating, and processing HTML, XML or other textual content for output generation on the web. http://genshi.edgewall.org/
-rw-r--r--testing/py-genshi/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-genshi/APKBUILD b/testing/py-genshi/APKBUILD
new file mode 100644
index 0000000000..394ef2943c
--- /dev/null
+++ b/testing/py-genshi/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-genshi
+_pkgname=Genshi
+pkgver=0.6
+pkgrel=0
+pkgdesc="Python toolkit for stream-based generation of output for the web"
+url="http://genshi.edgewall.org/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://ftp.edgewall.com/pub/genshi/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="604e8b23b4697655d36a69c2d8ef7187 Genshi-0.6.tar.gz"