summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-01-30 15:59:43 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-01-30 16:35:05 +0200
commitdb977d28b68269cd201a07d2490acef1d8e9de06 (patch)
tree8d61b1ddbc6f48ba7bfa755ac71b93c82b8b8dec
parent2277f8f07366c9ea59897434f291cace8abaed89 (diff)
downloadaports-fcolista-db977d28b68269cd201a07d2490acef1d8e9de06.tar.bz2
aports-fcolista-db977d28b68269cd201a07d2490acef1d8e9de06.tar.xz
testing/libmatroska: new aport
a C++ library to parse Matroska files http://www.matroska.org/
-rw-r--r--testing/libmatroska/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/libmatroska/APKBUILD b/testing/libmatroska/APKBUILD
new file mode 100644
index 0000000000..d0112705d7
--- /dev/null
+++ b/testing/libmatroska/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libmatroska
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="a C++ library to parse Matroska files"
+url="http://www.matroska.org/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="libebml-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -C make/linux
+}
+
+package() {
+ cd "$_builddir"
+ make -C make/linux install prefix="$pkgdir/usr"
+}
+
+md5sums="f4a8c411f09d39c754eb726efd616043 libmatroska-1.3.0.tar.bz2"