summaryrefslogtreecommitdiffstats
path: root/main/bitchx
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-01-02 17:45:09 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2013-01-02 17:45:26 -0600
commit72df2565c1fa8baa4b6e3b02364cc7f328b5752a (patch)
tree28838c1bed7b69b8c4f2f7278de025408bf2abf6 /main/bitchx
parent4a370150f533c16a858dc7904b9d52060c02e8eb (diff)
downloadaports-fcolista-72df2565c1fa8baa4b6e3b02364cc7f328b5752a.tar.bz2
aports-fcolista-72df2565c1fa8baa4b6e3b02364cc7f328b5752a.tar.xz
main/bitchx: new aport
Diffstat (limited to 'main/bitchx')
-rw-r--r--main/bitchx/APKBUILD50
-rw-r--r--main/bitchx/bitchx-busybox-cpio.patch11
2 files changed, 61 insertions, 0 deletions
diff --git a/main/bitchx/APKBUILD b/main/bitchx/APKBUILD
new file mode 100644
index 0000000000..befec8e3d4
--- /dev/null
+++ b/main/bitchx/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=bitchx
+pkgver=1.2
+pkgrel=0
+pkgdesc="BitchX irc client"
+url="http://bitchx.ca/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="tcl-dev openssl-dev"
+makedepends="$depends_dev coreutils"
+install=""
+subpackages="$pkgname-doc"
+source="http://bitchx.ca/BitchX-$pkgver-final.tar.gz
+ bitchx-busybox-cpio.patch"
+
+_builddir="$srcdir"/BitchX-1.2
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-ssl \
+ --with-ipv6 \
+ --with-plugins \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="5c4947f5a345574e28d93f78cb191ce4 BitchX-1.2-final.tar.gz
+76561954440fc1c5545f4a0f20a8c60c bitchx-busybox-cpio.patch"
diff --git a/main/bitchx/bitchx-busybox-cpio.patch b/main/bitchx/bitchx-busybox-cpio.patch
new file mode 100644
index 0000000000..f854749b5f
--- /dev/null
+++ b/main/bitchx/bitchx-busybox-cpio.patch
@@ -0,0 +1,11 @@
+--- BitchX-1.2/Makefile.in
++++ BitchX-1.2.mod/Makefile.in
+@@ -212,7 +212,7 @@
+
+ installhelp: installdirs
+ cd $(top_srcdir)/bitchx-docs && \
+- find . -name .svn -prune -o -print | cpio -pdmu -R `id -un`:`id -gn` "$(DESTDIR)$(HELPDIR)"
++ find . -name .svn -prune -o -print | cpio -pdmu "$(DESTDIR)$(HELPDIR)"
+ (find "$(DESTDIR)$(HELPDIR)" -type f ! -name '*.bz2' ! -name '*.gz' | \
+ (xargs bzip2 -9f || xargs gzip -9f) || :) 2>/dev/null
+