summaryrefslogtreecommitdiffstats
path: root/main/dansguardian
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-04 18:25:27 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-04 18:25:27 +0100
commit7a7174a3a06f5d4a07c1a049cc2fa924e5716217 (patch)
treedf587613fe8594604a2759dc8cf7ddab5d746230 /main/dansguardian
parent214e43f4e434ef172636950e117d32d1f2343647 (diff)
downloadaports-fcolista-7a7174a3a06f5d4a07c1a049cc2fa924e5716217.tar.bz2
aports-fcolista-7a7174a3a06f5d4a07c1a049cc2fa924e5716217.tar.xz
main/dansguardian: fix build with eglibc and gcc 4.6
Diffstat (limited to 'main/dansguardian')
-rw-r--r--main/dansguardian/APKBUILD6
-rw-r--r--main/dansguardian/gcc4.6.patch19
2 files changed, 23 insertions, 2 deletions
diff --git a/main/dansguardian/APKBUILD b/main/dansguardian/APKBUILD
index ee273743e6..4b3577d2a9 100644
--- a/main/dansguardian/APKBUILD
+++ b/main/dansguardian/APKBUILD
@@ -16,12 +16,13 @@ source="http://dansguardian.org/downloads/2/Stable/$pkgname-$pkgver.tar.gz
dansguardian.logrotate
ftp-credential.patch
dansguardian-2.10.1.1-gcc44.patch
- "
+ gcc4.6.patch"
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i ../ftp-credential.patch || return 1
patch -p1 -i ../dansguardian-2.10.1.1-gcc44.patch || return 1
+ patch -p1 -i ../gcc4.6.patch || return 1
# do not block "microsoft...clustimg=..." and similar
sed -e 's:\.\*:.{1,10}:g' configs/lists/bannedregexpurllist
@@ -46,4 +47,5 @@ md5sums="0987a1c9bfbdf398118386f10279611a dansguardian-2.10.1.1.tar.gz
feaa8582f8c0251a4bff76b5e05c9369 dansguardian.initd
85b6de01c9508e8ceff5ebb55752f8d3 dansguardian.logrotate
475c46026e8553181d293d5a4feaf6d9 ftp-credential.patch
-2c78b5c7346b8fcb3dee352e0c53cb5a dansguardian-2.10.1.1-gcc44.patch"
+2c78b5c7346b8fcb3dee352e0c53cb5a dansguardian-2.10.1.1-gcc44.patch
+858ea94750a9b32e7715f3da8ef4ae3c gcc4.6.patch"
diff --git a/main/dansguardian/gcc4.6.patch b/main/dansguardian/gcc4.6.patch
new file mode 100644
index 0000000000..e9f533e0d5
--- /dev/null
+++ b/main/dansguardian/gcc4.6.patch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 70-gcc4.6.dpatch by Daniel T Chen <crimsun@ubuntu.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix FTBFS by including cstddef for size_t
+
+@DPATCH@
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' dansguardian-2.10.1.1~/src/authplugins/ntlm.cpp dansguardian-2.10.1.1/src/authplugins/ntlm.cpp
+--- dansguardian-2.10.1.1~/src/authplugins/ntlm.cpp 2008-11-18 06:27:04.000000000 -0500
++++ dansguardian-2.10.1.1/src/authplugins/ntlm.cpp 2011-08-25 16:37:38.000000000 -0400
+@@ -27,6 +27,8 @@
+ #include "../FDTunnel.hpp"
+ #include "../OptionContainer.hpp"
+
++#include <cstddef>
++
+ #include <syslog.h>
+
+ #include <iconv.h>