summaryrefslogtreecommitdiffstats
path: root/main/freerdp/pluginpath.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-13 14:16:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-13 14:16:32 +0000
commitfe430eb80736e934fd81d92e385c15fe5a312ce0 (patch)
treed869bee83a4b35629a6e7b8a997f69c02cf7c4b4 /main/freerdp/pluginpath.patch
parente340ee3324d582f9d7c97faf08d39551b0f29349 (diff)
downloadaports-fcolista-fe430eb80736e934fd81d92e385c15fe5a312ce0.tar.bz2
aports-fcolista-fe430eb80736e934fd81d92e385c15fe5a312ce0.tar.xz
main/freerdp: build fix for x86_64
we want use /usr/lib instead of /usr/lib64 but at the same time we don't want install the plugins in /usr/usr/lib
Diffstat (limited to 'main/freerdp/pluginpath.patch')
-rw-r--r--main/freerdp/pluginpath.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/freerdp/pluginpath.patch b/main/freerdp/pluginpath.patch
new file mode 100644
index 0000000000..4a9349b2c0
--- /dev/null
+++ b/main/freerdp/pluginpath.patch
@@ -0,0 +1,11 @@
+--- ./CMakeLists.txt.orig
++++ ./CMakeLists.txt
+@@ -127,7 +127,7 @@
+ set(FREERDP_KEYMAP_PATH "${CMAKE_INSTALL_PREFIX}/freerdp/keymaps")
+
+ # Path to put plugins
+-set(FREERDP_PLUGIN_PATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/freerdp")
++set(FREERDP_PLUGIN_PATH "${CMAKE_INSTALL_LIBDIR}/freerdp")
+
+ # Include directories
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})