summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-14 15:41:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-14 15:41:02 +0000
commit287e24b281efdce56e63dca314b4e802f8092527 (patch)
tree0db43bb74fa7bb5da1ed144ca959afa416a615ae /main/freeswitch
parentdf98aafaf6844613275bbbcd1b26e839902fa038 (diff)
downloadaports-fcolista-287e24b281efdce56e63dca314b4e802f8092527.tar.bz2
aports-fcolista-287e24b281efdce56e63dca314b4e802f8092527.tar.xz
main/freeswitch: move default config to separate subpackage
Deleted files will be re-added otherwise on upgrade
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 56aed8ea76..ef178e7e57 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=9
+pkgrel=10
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -10,7 +10,7 @@ depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
autoconf automake libtool"
install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-dev $pkgname-flite"
+subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
modules.conf
freeswitch.confd
@@ -80,6 +80,17 @@ flite() {
mod_say_it mod_say_nl mod_say_zh
}
+conf() {
+ pkgdesc="Freeswitch sample configureation"
+ depends="freeswitch"
+ install=
+ mkdir -p "$subpkgdir"/etc/freeswich
+ # move all configs except freeswitch.xml
+ for i in "$pkgdir"/etc/freeswitch/*; do
+ [ "$i" = "$pkgdir"/etc/freeswitch/freeswitch.xml ] && continue
+ mv "$i" "$subpkgdir"/etc/freeswitch/ || return 1
+ done
+}
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
55e62842ad037e5e550ad097df09f6d2 modules.conf