summaryrefslogtreecommitdiffstats
path: root/main/icon-naming-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/icon-naming-utils
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-fcolista-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-fcolista-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/icon-naming-utils')
-rw-r--r--main/icon-naming-utils/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/icon-naming-utils/APKBUILD b/main/icon-naming-utils/APKBUILD
new file mode 100644
index 0000000000..b5164dd05a
--- /dev/null
+++ b/main/icon-naming-utils/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=icon-naming-utils
+pkgver=0.8.90
+pkgrel=0
+pkgdesc="Maps the new names of icons for Tango to the legacy names used by the GNOME and KDE desktops."
+url="http://tango.freedesktop.org/"
+license="GPL"
+depends="perl-xml-simple"
+makedepends=""
+source="http://tango.freedesktop.org/releases/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/icon-naming-utils \
+ --localstatedir=/var || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/pkgconfig || return 1
+ chmod +x "$pkgdir"/usr/lib/icon-naming-utils/icon-name-mapping
+}
+
+md5sums="dd8108b56130b9eedc4042df634efa66 icon-naming-utils-0.8.90.tar.bz2"