summaryrefslogtreecommitdiffstats
path: root/main/inkscape
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 21:07:33 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 21:07:33 -0500
commit29400357397185cfab3ca07e43379fcfdf989e08 (patch)
tree53aa0ee953f6a017546e7db5a56a164889c308d7 /main/inkscape
parentd88c8ba6432f924c155156031f5d1cc06f72e09b (diff)
downloadaports-fcolista-29400357397185cfab3ca07e43379fcfdf989e08.tar.bz2
aports-fcolista-29400357397185cfab3ca07e43379fcfdf989e08.tar.xz
main/inkscape: fix compilation under libpng 1.5
Diffstat (limited to 'main/inkscape')
-rw-r--r--main/inkscape/APKBUILD5
-rw-r--r--main/inkscape/inkscape-png15.patch33
2 files changed, 36 insertions, 2 deletions
diff --git a/main/inkscape/APKBUILD b/main/inkscape/APKBUILD
index 6b844f7755..2f30df8941 100644
--- a/main/inkscape/APKBUILD
+++ b/main/inkscape/APKBUILD
@@ -24,7 +24,7 @@ autoconf automake
depends="desktop-file-utils"
install=
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
- "
+ inkscape-png15.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -56,4 +56,5 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="3c179eb998d49d1c312822e15773bf6d inkscape-0.48.1.tar.gz"
+md5sums="3c179eb998d49d1c312822e15773bf6d inkscape-0.48.1.tar.gz
+c2d1392e6489af822cb4b41ce3af877b inkscape-png15.patch"
diff --git a/main/inkscape/inkscape-png15.patch b/main/inkscape/inkscape-png15.patch
new file mode 100644
index 0000000000..7318adc5d6
--- /dev/null
+++ b/main/inkscape/inkscape-png15.patch
@@ -0,0 +1,33 @@
+--- inkscape-0.48.1.orig/src/sp-image.cpp
++++ inkscape-0.48.1/src/sp-image.cpp
+@@ -388,7 +388,7 @@
+ {
+ char* name = 0;
+ int compression_type = 0;
+- char* profile = 0;
++ png_byte* profile = 0;
+ png_uint_32 proflen = 0;
+ if ( png_get_iCCP(pngPtr, infoPtr, &name, &compression_type, &profile, &proflen) ) {
+ // g_message("Found an iCCP chunk named [%s] with %d bytes and comp %d", name, proflen, compression_type);
+--- inkscape-0.48.1.orig/src/helper/png-write.cpp
++++ inkscape-0.48.1/src/helper/png-write.cpp
+@@ -165,7 +165,7 @@
+ /* Set error handling. REQUIRED if you aren't supplying your own
+ * error hadnling functions in the png_create_write_struct() call.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file */
+ fclose(fp);
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+--- inkscape-0.48.1.orig/src/extension/internal/pdfinput/svg-builder.cpp
++++ inkscape-0.48.1/src/extension/internal/pdfinput/svg-builder.cpp
+@@ -1443,7 +1443,7 @@
+ return NULL;
+ }
+ // Set error handler
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ return NULL;
+ }