summaryrefslogtreecommitdiffstats
path: root/main/inkscape
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-18 08:07:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-18 08:07:12 +0000
commitb2150537cf754f767a4a8c74c9456ab37c921fc5 (patch)
tree48086cb57755f8e30d418270abab50673a0d1c3e /main/inkscape
parent01df817743c82366f7427f5568426fbc34aa3767 (diff)
downloadaports-fcolista-b2150537cf754f767a4a8c74c9456ab37c921fc5.tar.bz2
aports-fcolista-b2150537cf754f767a4a8c74c9456ab37c921fc5.tar.xz
main/inkscape: upgrade to 0.48.4
Diffstat (limited to 'main/inkscape')
-rw-r--r--main/inkscape/APKBUILD12
-rw-r--r--main/inkscape/inkscape-png15.patch33
-rw-r--r--main/inkscape/poppler20.patch642
3 files changed, 4 insertions, 683 deletions
diff --git a/main/inkscape/APKBUILD b/main/inkscape/APKBUILD
index 77646e64ca..7228b050fb 100644
--- a/main/inkscape/APKBUILD
+++ b/main/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
-pkgver=0.48.3.1
-pkgrel=6
+pkgver=0.48.4
+pkgrel=0
pkgdesc="A vector-based drawing program - svg compliant"
url="http://inkscape.sourceforge.net/"
arch="all"
@@ -25,9 +25,7 @@ tar
depends="desktop-file-utils"
install=
subpackages="$pkgname-lang"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
- inkscape-png15.patch
- poppler20.patch"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -59,6 +57,4 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="ccf8ccd9e66199badb8c35ea3851a888 inkscape-0.48.3.1.tar.gz
-c2d1392e6489af822cb4b41ce3af877b inkscape-png15.patch
-e5b13a78d073150367749b93f5605ffb poppler20.patch"
+md5sums="2c7149e877609f3f7e7a9d4e6f510d2b inkscape-0.48.4.tar.gz"
diff --git a/main/inkscape/inkscape-png15.patch b/main/inkscape/inkscape-png15.patch
deleted file mode 100644
index 7318adc5d6..0000000000
--- a/main/inkscape/inkscape-png15.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- inkscape-0.48.1.orig/src/sp-image.cpp
-+++ inkscape-0.48.1/src/sp-image.cpp
-@@ -388,7 +388,7 @@
- {
- char* name = 0;
- int compression_type = 0;
-- char* profile = 0;
-+ png_byte* profile = 0;
- png_uint_32 proflen = 0;
- if ( png_get_iCCP(pngPtr, infoPtr, &name, &compression_type, &profile, &proflen) ) {
- // g_message("Found an iCCP chunk named [%s] with %d bytes and comp %d", name, proflen, compression_type);
---- inkscape-0.48.1.orig/src/helper/png-write.cpp
-+++ inkscape-0.48.1/src/helper/png-write.cpp
-@@ -165,7 +165,7 @@
- /* Set error handling. REQUIRED if you aren't supplying your own
- * error hadnling functions in the png_create_write_struct() call.
- */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* If we get here, we had a problem reading the file */
- fclose(fp);
- png_destroy_write_struct(&png_ptr, &info_ptr);
---- inkscape-0.48.1.orig/src/extension/internal/pdfinput/svg-builder.cpp
-+++ inkscape-0.48.1/src/extension/internal/pdfinput/svg-builder.cpp
-@@ -1443,7 +1443,7 @@
- return NULL;
- }
- // Set error handler
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- return NULL;
- }
diff --git a/main/inkscape/poppler20.patch b/main/inkscape/poppler20.patch
deleted file mode 100644
index ecb74603fd..0000000000
--- a/main/inkscape/poppler20.patch
+++ /dev/null
@@ -1,642 +0,0 @@
-diff -Naur old/src/extension/internal/pdfinput/pdf-parser.cpp new/src/extension/internal/pdfinput/pdf-parser.cpp
---- old/src/extension/internal/pdfinput/pdf-parser.cpp 2011-07-08 20:25:09.468790000 +0200
-+++ new/src/extension/internal/pdfinput/pdf-parser.cpp 2012-05-13 21:07:11.334781215 +0200
-@@ -367,14 +367,14 @@
- for (i = 0; i < obj->arrayGetLength(); ++i) {
- obj->arrayGet(i, &obj2);
- if (!obj2.isStream()) {
-- error(-1, const_cast<char*>("Weird page contents"));
-+ error(errInternal, -1, const_cast<char*>("Weird page contents"));
- obj2.free();
- return;
- }
- obj2.free();
- }
- } else if (!obj->isStream()) {
-- error(-1, const_cast<char*>("Weird page contents"));
-+ error(errInternal, -1, const_cast<char*>("Weird page contents"));
- return;
- }
- parser = new Parser(xref, new Lexer(xref, obj), gFalse);
-@@ -419,7 +419,7 @@
-
- // too many arguments - something is wrong
- } else {
-- error(getPos(), const_cast<char*>("Too many args in content stream"));
-+ error(errInternal, getPos(), const_cast<char*>("Too many args in content stream"));
- if (printCommands) {
- printf("throwing away arg: ");
- obj.print(stdout);
-@@ -436,7 +436,7 @@
-
- // args at end with no command
- if (numArgs > 0) {
-- error(getPos(), const_cast<char*>("Leftover args in content stream"));
-+ error(errInternal, getPos(), const_cast<char*>("Leftover args in content stream"));
- if (printCommands) {
- printf("%d leftovers:", numArgs);
- for (i = 0; i < numArgs; ++i) {
-@@ -502,7 +502,7 @@
- name = cmd->getCmd();
- if (!(op = findOp(name))) {
- if (ignoreUndef == 0)
-- error(getPos(), const_cast<char*>("Unknown operator '%s'"), name);
-+ error(errInternal, getPos(), const_cast<char*>("Unknown operator '%s'"), name);
- return;
- }
-
-@@ -510,26 +510,26 @@
- argPtr = args;
- if (op->numArgs >= 0) {
- if (numArgs < op->numArgs) {
-- error(getPos(), const_cast<char*>("Too few (%d) args to '%s' operator"), numArgs, name);
-+ error(errInternal, getPos(), const_cast<char*>("Too few (%d) args to '%s' operator"), numArgs, name);
- return;
- }
- if (numArgs > op->numArgs) {
- #if 0
-- error(getPos(), "Too many (%d) args to '%s' operator", numArgs, name);
-+ error(errInternal, getPos(), "Too many (%d) args to '%s' operator", numArgs, name);
- #endif
- argPtr += numArgs - op->numArgs;
- numArgs = op->numArgs;
- }
- } else {
- if (numArgs > -op->numArgs) {
-- error(getPos(), const_cast<char*>("Too many (%d) args to '%s' operator"),
-+ error(errInternal, getPos(), const_cast<char*>("Too many (%d) args to '%s' operator"),
- numArgs, name);
- return;
- }
- }
- for (i = 0; i < numArgs; ++i) {
- if (!checkArg(&argPtr[i], op->tchk[i])) {
-- error(getPos(), const_cast<char*>("Arg #%d to '%s' operator is wrong type (%s)"),
-+ error(errInternal, getPos(), const_cast<char*>("Arg #%d to '%s' operator is wrong type (%s)"),
- i, name, argPtr[i].getTypeName());
- return;
- }
-@@ -690,7 +690,7 @@
- return;
- }
- if (!obj1.isDict()) {
-- error(getPos(), const_cast<char*>("ExtGState '%s' is wrong type"), args[0].getName());
-+ error(errInternal, getPos(), const_cast<char*>("ExtGState '%s' is wrong type"), args[0].getName());
- obj1.free();
- return;
- }
-@@ -705,7 +705,7 @@
- if (state->parseBlendMode(&obj2, &mode)) {
- state->setBlendMode(mode);
- } else {
-- error(getPos(), const_cast<char*>("Invalid blend mode in ExtGState"));
-+ error(errInternal, getPos(), const_cast<char*>("Invalid blend mode in ExtGState"));
- }
- }
- obj2.free();
-@@ -764,7 +764,7 @@
- state->setTransfer(funcs);
- }
- } else if (!obj2.isNull()) {
-- error(getPos(), const_cast<char*>("Invalid transfer function in ExtGState"));
-+ error(errInternal, getPos(), const_cast<char*>("Invalid transfer function in ExtGState"));
- }
- obj2.free();
-
-@@ -784,7 +784,7 @@
- funcs[0] = Function::parse(&obj3);
- if (funcs[0]->getInputSize() != 1 ||
- funcs[0]->getOutputSize() != 1) {
-- error(getPos(),
-+ error(errInternal, getPos(),
- const_cast<char*>("Invalid transfer function in soft mask in ExtGState"));
- delete funcs[0];
- funcs[0] = NULL;
-@@ -809,11 +809,7 @@
- blendingColorSpace = NULL;
- isolated = knockout = gFalse;
- if (!obj4.dictLookup(const_cast<char*>("CS"), &obj5)->isNull()) {
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- blendingColorSpace = GfxColorSpace::parse(&obj5, NULL);
--#else
-- blendingColorSpace = GfxColorSpace::parse(&obj5);
--#endif
- }
- obj5.free();
- if (obj4.dictLookup(const_cast<char*>("I"), &obj5)->isBool()) {
-@@ -840,15 +836,15 @@
- delete funcs[0];
- }
- } else {
-- error(getPos(), const_cast<char*>("Invalid soft mask in ExtGState - missing group"));
-+ error(errInternal, getPos(), const_cast<char*>("Invalid soft mask in ExtGState - missing group"));
- }
- obj4.free();
- } else {
-- error(getPos(), const_cast<char*>("Invalid soft mask in ExtGState - missing group"));
-+ error(errInternal, getPos(), const_cast<char*>("Invalid soft mask in ExtGState - missing group"));
- }
- obj3.free();
- } else if (!obj2.isNull()) {
-- error(getPos(), const_cast<char*>("Invalid soft mask in ExtGState"));
-+ error(errInternal, getPos(), const_cast<char*>("Invalid soft mask in ExtGState"));
- }
- }
- obj2.free();
-@@ -876,7 +872,7 @@
- // check form type
- dict->lookup(const_cast<char*>("FormType"), &obj1);
- if (!(obj1.isNull() || (obj1.isInt() && obj1.getInt() == 1))) {
-- error(getPos(), const_cast<char*>("Unknown form type"));
-+ error(errInternal, getPos(), const_cast<char*>("Unknown form type"));
- }
- obj1.free();
-
-@@ -884,7 +880,7 @@
- dict->lookup(const_cast<char*>("BBox"), &obj1);
- if (!obj1.isArray()) {
- obj1.free();
-- error(getPos(), const_cast<char*>("Bad form bounding box"));
-+ error(errInternal, getPos(), const_cast<char*>("Bad form bounding box"));
- return;
- }
- for (i = 0; i < 4; ++i) {
-@@ -1012,19 +1008,11 @@
-
- state->setFillPattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- if (obj.isNull()) {
- colorSpace = GfxColorSpace::parse(&args[0], NULL);
- } else {
- colorSpace = GfxColorSpace::parse(&obj, NULL);
- }
--#else
-- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-- }
--#endif
- obj.free();
- if (colorSpace) {
- state->setFillColorSpace(colorSpace);
-@@ -1032,7 +1020,7 @@
- state->setFillColor(&color);
- builder->updateStyle(state);
- } else {
-- error(getPos(), const_cast<char*>("Bad color space (fill)"));
-+ error(errInternal, getPos(), const_cast<char*>("Bad color space (fill)"));
- }
- }
-
-@@ -1043,19 +1031,11 @@
-
- state->setStrokePattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- if (obj.isNull()) {
- colorSpace = GfxColorSpace::parse(&args[0], NULL);
- } else {
- colorSpace = GfxColorSpace::parse(&obj, NULL);
- }
--#else
-- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-- }
--#endif
- obj.free();
- if (colorSpace) {
- state->setStrokeColorSpace(colorSpace);
-@@ -1063,7 +1043,7 @@
- state->setStrokeColor(&color);
- builder->updateStyle(state);
- } else {
-- error(getPos(), const_cast<char*>("Bad color space (stroke)"));
-+ error(errInternal, getPos(), const_cast<char*>("Bad color space (stroke)"));
- }
- }
-
-@@ -1072,7 +1052,7 @@
- int i;
-
- if (numArgs != state->getFillColorSpace()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'sc' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'sc' command"));
- return;
- }
- state->setFillPattern(NULL);
-@@ -1088,7 +1068,7 @@
- int i;
-
- if (numArgs != state->getStrokeColorSpace()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'SC' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'SC' command"));
- return;
- }
- state->setStrokePattern(NULL);
-@@ -1109,7 +1089,7 @@
- if (!((GfxPatternColorSpace *)state->getFillColorSpace())->getUnder() ||
- numArgs - 1 != ((GfxPatternColorSpace *)state->getFillColorSpace())
- ->getUnder()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'scn' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'scn' command"));
- return;
- }
- for (i = 0; i < numArgs - 1 && i < gfxColorMaxComps; ++i) {
-@@ -1120,23 +1100,15 @@
- state->setFillColor(&color);
- builder->updateStyle(state);
- }
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- if (args[numArgs-1].isName() &&
- (pattern = res->lookupPattern(args[numArgs-1].getName(), NULL))) {
- state->setFillPattern(pattern);
- builder->updateStyle(state);
- }
--#else
-- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-- state->setFillPattern(pattern);
-- builder->updateStyle(state);
-- }
--#endif
-
- } else {
- if (numArgs != state->getFillColorSpace()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'scn' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'scn' command"));
- return;
- }
- state->setFillPattern(NULL);
-@@ -1161,7 +1133,7 @@
- ->getUnder() ||
- numArgs - 1 != ((GfxPatternColorSpace *)state->getStrokeColorSpace())
- ->getUnder()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'SCN' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'SCN' command"));
- return;
- }
- for (i = 0; i < numArgs - 1 && i < gfxColorMaxComps; ++i) {
-@@ -1172,23 +1144,15 @@
- state->setStrokeColor(&color);
- builder->updateStyle(state);
- }
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- if (args[numArgs-1].isName() &&
- (pattern = res->lookupPattern(args[numArgs-1].getName(), NULL))) {
- state->setStrokePattern(pattern);
- builder->updateStyle(state);
- }
--#else
-- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-- state->setStrokePattern(pattern);
-- builder->updateStyle(state);
-- }
--#endif
-
- } else {
- if (numArgs != state->getStrokeColorSpace()->getNComps()) {
-- error(getPos(), const_cast<char*>("Incorrect number of arguments in 'SCN' command"));
-+ error(errInternal, getPos(), const_cast<char*>("Incorrect number of arguments in 'SCN' command"));
- return;
- }
- state->setStrokePattern(NULL);
-@@ -1212,7 +1176,7 @@
-
- void PdfParser::opLineTo(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- error(getPos(), const_cast<char*>("No current point in lineto"));
-+ error(errInternal, getPos(), const_cast<char*>("No current point in lineto"));
- return;
- }
- state->lineTo(args[0].getNum(), args[1].getNum());
-@@ -1222,7 +1186,7 @@
- double x1, y1, x2, y2, x3, y3;
-
- if (!state->isCurPt()) {
-- error(getPos(), const_cast<char*>("No current point in curveto"));
-+ error(errInternal, getPos(), const_cast<char*>("No current point in curveto"));
- return;
- }
- x1 = args[0].getNum();
-@@ -1238,7 +1202,7 @@
- double x1, y1, x2, y2, x3, y3;
-
- if (!state->isCurPt()) {
-- error(getPos(), const_cast<char*>("No current point in curveto1"));
-+ error(errInternal, getPos(), const_cast<char*>("No current point in curveto1"));
- return;
- }
- x1 = state->getCurX();
-@@ -1254,7 +1218,7 @@
- double x1, y1, x2, y2, x3, y3;
-
- if (!state->isCurPt()) {
-- error(getPos(), const_cast<char*>("No current point in curveto2"));
-+ error(errInternal, getPos(), const_cast<char*>("No current point in curveto2"));
- return;
- }
- x1 = args[0].getNum();
-@@ -1282,7 +1246,7 @@
-
- void PdfParser::opClosePath(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- error(getPos(), const_cast<char*>("No current point in closepath"));
-+ error(errInternal, getPos(), const_cast<char*>("No current point in closepath"));
- return;
- }
- state->closePath();
-@@ -1298,7 +1262,7 @@
-
- void PdfParser::opStroke(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in stroke"));
- return;
- }
- if (state->isPath()) {
-@@ -1314,7 +1278,7 @@
-
- void PdfParser::opCloseStroke(Object * /*args[]*/, int /*numArgs*/) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in closepath/stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in closepath/stroke"));
- return;
- }
- state->closePath();
-@@ -1331,7 +1295,7 @@
-
- void PdfParser::opFill(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in fill"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in fill"));
- return;
- }
- if (state->isPath()) {
-@@ -1347,7 +1311,7 @@
-
- void PdfParser::opEOFill(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in eofill"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in eofill"));
- return;
- }
- if (state->isPath()) {
-@@ -1363,7 +1327,7 @@
-
- void PdfParser::opFillStroke(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in fill/stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in fill/stroke"));
- return;
- }
- if (state->isPath()) {
-@@ -1376,7 +1340,7 @@
-
- void PdfParser::opCloseFillStroke(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in closepath/fill/stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in closepath/fill/stroke"));
- return;
- }
- if (state->isPath()) {
-@@ -1388,7 +1352,7 @@
-
- void PdfParser::opEOFillStroke(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in eofill/stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in eofill/stroke"));
- return;
- }
- if (state->isPath()) {
-@@ -1399,7 +1363,7 @@
-
- void PdfParser::opCloseEOFillStroke(Object args[], int numArgs) {
- if (!state->isCurPt()) {
-- //error(getPos(), const_cast<char*>("No path in closepath/eofill/stroke"));
-+ //error(errInternal, getPos(), const_cast<char*>("No path in closepath/eofill/stroke"));
- return;
- }
- if (state->isPath()) {
-@@ -1440,7 +1404,7 @@
- doShadingPatternFillFallback((GfxShadingPattern *)pattern, gFalse, eoFill);
- break;
- default:
-- error(getPos(), const_cast<char*>("Unimplemented pattern type (%d) in fill"),
-+ error(errInternal, getPos(), const_cast<char*>("Unimplemented pattern type (%d) in fill"),
- pattern->getType());
- break;
- }
-@@ -1459,7 +1423,7 @@
- doShadingPatternFillFallback((GfxShadingPattern *)pattern, gTrue, gFalse);
- break;
- default:
-- error(getPos(), const_cast<char*>("Unimplemented pattern type (%d) in stroke"),
-+ error(errInternal, getPos(), const_cast<char*>("Unimplemented pattern type (%d) in stroke"),
- pattern->getType());
- break;
- }
-@@ -1579,15 +1543,9 @@
- double *matrix = NULL;
- GBool savedState = gFalse;
-
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- if (!(shading = res->lookupShading(args[0].getName(), NULL))) {
- return;
- }
--#else
-- if (!(shading = res->lookupShading(args[0].getName()))) {
-- return;
-- }
--#endif
-
- // save current graphics state
- if (shading->getType() != 2 && shading->getType() != 3) {
-@@ -2156,7 +2114,7 @@
-
- void PdfParser::opShowText(Object args[], int numArgs) {
- if (!state->getFont()) {
-- error(getPos(), const_cast<char*>("No font in show"));
-+ error(errInternal, getPos(), const_cast<char*>("No font in show"));
- return;
- }
- if (fontChanged) {
-@@ -2170,7 +2128,7 @@
- double tx, ty;
-
- if (!state->getFont()) {
-- error(getPos(), const_cast<char*>("No font in move/show"));
-+ error(errInternal, getPos(), const_cast<char*>("No font in move/show"));
- return;
- }
- if (fontChanged) {
-@@ -2188,7 +2146,7 @@
- double tx, ty;
-
- if (!state->getFont()) {
-- error(getPos(), const_cast<char*>("No font in move/set/show"));
-+ error(errInternal, getPos(), const_cast<char*>("No font in move/set/show"));
- return;
- }
- if (fontChanged) {
-@@ -2211,7 +2169,7 @@
- int i;
-
- if (!state->getFont()) {
-- error(getPos(), const_cast<char*>("No font in show/space"));
-+ error(errInternal, getPos(), const_cast<char*>("No font in show/space"));
- return;
- }
- if (fontChanged) {
-@@ -2236,7 +2194,7 @@
- } else if (obj.isString()) {
- doShowText(obj.getString());
- } else {
-- error(getPos(), const_cast<char*>("Element of show/space array must be number or string"));
-+ error(errInternal, getPos(), const_cast<char*>("Element of show/space array must be number or string"));
- }
- obj.free();
- }
-@@ -2334,7 +2292,7 @@
- if (charProc.isStream()) {
- //parse(&charProc, gFalse); // TODO: parse into SVG font
- } else {
-- error(getPos(), const_cast<char*>("Missing or bad Type3 CharProc entry"));
-+ error(errInternal, getPos(), const_cast<char*>("Missing or bad Type3 CharProc entry"));
- }
- //out->endType3Char(state);
- if (resDict) {
-@@ -2410,7 +2368,7 @@
- return;
- }
- if (!obj1.isStream()) {
-- error(getPos(), const_cast<char*>("XObject '%s' is wrong type"), name);
-+ error(errInternal, getPos(), const_cast<char*>("XObject '%s' is wrong type"), name);
- obj1.free();
- return;
- }
-@@ -2426,9 +2384,9 @@
- /* out->psXObject(obj1.getStream(),
- obj3.isStream() ? obj3.getStream() : (Stream *)NULL);*/
- } else if (obj2.isName()) {
-- error(getPos(), const_cast<char*>("Unknown XObject subtype '%s'"), obj2.getName());
-+ error(errInternal, getPos(), const_cast<char*>("Unknown XObject subtype '%s'"), obj2.getName());
- } else {
-- error(getPos(), const_cast<char*>("XObject subtype is missing or wrong type"));
-+ error(errInternal, getPos(), const_cast<char*>("XObject subtype is missing or wrong type"));
- }
- obj2.free();
- obj1.free();
-@@ -2559,11 +2517,7 @@
- }
- }
- if (!obj1.isNull()) {
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- colorSpace = GfxColorSpace::parse(&obj1, NULL);
--#else
-- colorSpace = GfxColorSpace::parse(&obj1);
--#endif
- } else if (csMode == streamCSDeviceGray) {
- colorSpace = new GfxDeviceGrayColorSpace();
- } else if (csMode == streamCSDeviceRGB) {
-@@ -2648,11 +2602,7 @@
- obj2.free();
- }
- }
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- maskColorSpace = GfxColorSpace::parse(&obj1, NULL);
--#else
-- maskColorSpace = GfxColorSpace::parse(&obj1);
--#endif
- obj1.free();
- if (!maskColorSpace || maskColorSpace->getMode() != csDeviceGray) {
- goto err1;
-@@ -2758,7 +2708,7 @@
- err2:
- obj1.free();
- err1:
-- error(getPos(), const_cast<char*>("Bad image parameters"));
-+ error(errInternal, getPos(), const_cast<char*>("Bad image parameters"));
- }
-
- void PdfParser::doForm(Object *str) {
-@@ -2783,7 +2733,7 @@
- // check form type
- dict->lookup(const_cast<char*>("FormType"), &obj1);
- if (!(obj1.isNull() || (obj1.isInt() && obj1.getInt() == 1))) {
-- error(getPos(), const_cast<char*>("Unknown form type"));
-+ error(errInternal, getPos(), const_cast<char*>("Unknown form type"));
- }
- obj1.free();
-
-@@ -2791,7 +2741,7 @@
- dict->lookup(const_cast<char*>("BBox"), &bboxObj);
- if (!bboxObj.isArray()) {
- bboxObj.free();
-- error(getPos(), const_cast<char*>("Bad form bounding box"));
-+ error(errInternal, getPos(), const_cast<char*>("Bad form bounding box"));
- return;
- }
- for (i = 0; i < 4; ++i) {
-@@ -2827,11 +2777,7 @@
- if (obj1.dictLookup(const_cast<char*>("S"), &obj2)->isName(const_cast<char*>("Transparency"))) {
- transpGroup = gTrue;
- if (!obj1.dictLookup(const_cast<char*>("CS"), &obj3)->isNull()) {
--#ifdef POPPLER_NEW_COLOR_SPACE_API
- blendingColorSpace = GfxColorSpace::parse(&obj3, NULL);
--#else
-- blendingColorSpace = GfxColorSpace::parse(&obj3);
--#endif
- }
- obj3.free();
- if (obj1.dictLookup(const_cast<char*>("I"), &obj3)->isBool()) {
-@@ -2990,7 +2936,7 @@
- parser->getObj(&obj);
- while (!obj.isCmd(const_cast<char*>("ID")) && !obj.isEOF()) {
- if (!obj.isName()) {
-- error(getPos(), const_cast<char*>("Inline image dictionary key must be a name object"));
-+ error(errInternal, getPos(), const_cast<char*>("Inline image dictionary key must be a name object"));
- obj.free();
- } else {
- key = copyString(obj.getName());
-@@ -3005,7 +2951,7 @@
- parser->getObj(&obj);
- }
- if (obj.isEOF()) {
-- error(getPos(), const_cast<char*>("End of file in inline image"));
-+ error(errInternal, getPos(), const_cast<char*>("End of file in inline image"));
- obj.free();
- dict.free();
- return NULL;
-@@ -3020,11 +2966,11 @@
- }
-
- void PdfParser::opImageData(Object args[], int numArgs) {
-- error(getPos(), const_cast<char*>("Internal: got 'ID' operator"));
-+ error(errInternal, getPos(), const_cast<char*>("Internal: got 'ID' operator"));
- }
-
- void PdfParser::opEndImage(Object args[], int numArgs) {
-- error(getPos(), const_cast<char*>("Internal: got 'EI' operator"));
-+ error(errInternal, getPos(), const_cast<char*>("Internal: got 'EI' operator"));
- }
-
- //------------------------------------------------------------------------
-diff -Naur old/src/extension/internal/pdfinput/svg-builder.cpp new/src/extension/internal/pdfinput/svg-builder.cpp
---- old/src/extension/internal/pdfinput/svg-builder.cpp 2011-07-08 20:25:09.468790000 +0200
-+++ new/src/extension/internal/pdfinput/svg-builder.cpp 2012-05-13 20:45:22.303804308 +0200
-@@ -961,9 +961,7 @@
- _font_style = sp_repr_css_attr_new();
- GfxFont *font = state->getFont();
- // Store original name
-- if (font->getOrigName()) {
-- _font_specification = font->getOrigName()->getCString();
-- } else if (font->getName()) {
-+ if (font->getName()) {
- _font_specification = font->getName()->getCString();
- } else {
- _font_specification = (char*) "Arial";